Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th May 2006, 22:12
disasm disasm is offline
Junior Member
 
Join Date: Jan 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix with smtps fails (port 465)

Postfix works fine with TLS on port 25, but when connecting on 465, it disconnects right away, and leaves this in the log file:

Code:
May 28 16:01:25 localhost postfix/smtpd[5735]: warning: connect to private/tlsmgr: Connection refused
May 28 16:01:25 localhost postfix/smtpd[5735]: warning: problem talking to server private/tlsmgr: Connection refused
May 28 16:01:26 localhost postfix/smtpd[5735]: warning: connect to private/tlsmgr: Connection refused
May 28 16:01:26 localhost postfix/smtpd[5735]: warning: problem talking to server private/tlsmgr: Connection refused
May 28 16:01:26 localhost postfix/smtpd[5735]: warning: no entropy for TLS key generation: disabling TLS support
May 28 16:01:26 localhost postfix/smtpd[5735]: connect from localhost.localdomain[127.0.0.1]
May 28 16:01:26 localhost postfix/smtpd[5735]: setting up TLS connection from localhost.localdomain[127.0.0.1]
May 28 16:01:26 localhost postfix/smtpd[5735]: Could not allocate 'TLScontext->con' with SSL_new()
May 28 16:01:26 localhost postfix/smtpd[5735]: warning: TLS library problem: 5735:error:140BA0C3:SSL routines:SSL_new:null ssl ctx:ssl_lib.c:231:
May 28 16:01:26 localhost postfix/smtpd[5735]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
May 28 16:01:26 localhost postfix/smtpd[5735]: disconnect from localhost.localdomain[127.0.0.1]
master.cf has these important lines:

Code:
# only used by postfix-tls                                                                                                                                                            
tlsmgr    fifo  -   -   n   300 1   tlsmgr                                                                                                                                            
smtps     inet  n   -   n   -   -   smtpd -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes                                                                                  
587   inet  n   -   n   -   -   smtpd -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
Reply With Quote
Sponsored Links
  #2  
Old 28th May 2006, 22:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

The error should be gone if you comment out
Code:
tlsmgr    fifo  -   -   n   300 1   tlsmgr
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix SMTP Port 25 Problem/Question ccix Installation/Configuration 26 6th August 2011 18:13
How to use Postfix with alternate port (26)? AgeOfPenguins-com Installation/Configuration 1 10th May 2006 23:41
set up MSA port 587 on Postfix ebbay Server Operation 2 21st April 2006 12:28
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 15:20


All times are GMT +2. The time now is 06:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.