#1  
Old 26th April 2010, 04:35
axtoxic107 axtoxic107 is offline
Junior Member
 
Join Date: Apr 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default change bind9 port

Hello,

When i restart my bind9 i face this message

Code:
Apr 26 03:01:32 imagezza named[1872]: loading configuration from '/etc/bind/named.conf'
Apr 26 03:01:32 imagezza named[1872]: max open files (1024) is smaller than max sockets (4096)
Apr 26 03:01:32 imagezza named[1872]: using default UDP/IPv4 port range: [1024, 65535]
Apr 26 03:01:32 imagezza named[1872]: using default UDP/IPv6 port range: [1024, 65535]
Apr 26 03:01:32 imagezza named[1872]: listening on IPv6 interfaces, port 53
Apr 26 03:01:32 imagezza named[1872]: listening on IPv4 interface lo, 127.0.0.1#53
Apr 26 03:01:32 imagezza named[1872]: could not listen on UDP socket: address in use
Apr 26 03:01:32 imagezza named[1872]: creating IPv4 interface lo failed; interface ignored
Apr 26 03:01:32 imagezza named[1872]: listening on IPv4 interface venet0, 127.0.0.1#53
Apr 26 03:01:32 imagezza named[1872]: could not listen on UDP socket: address in use
Apr 26 03:01:32 imagezza named[1872]: creating IPv4 interface venet0 failed; interface ignored
Apr 26 03:01:32 imagezza named[1872]: listening on IPv4 interface venet0:0, 184.82.19.178#53
Apr 26 03:01:32 imagezza named[1872]: could not listen on UDP socket: address in use
Apr 26 03:01:32 imagezza named[1872]: creating IPv4 interface venet0:0 failed; interface ignored
Apr 26 03:01:32 imagezza named[1872]: listening on IPv4 interface venet0:1, 184.82.19.179#53
Apr 26 03:01:32 imagezza named[1872]: could not listen on UDP socket: address in use
Apr 26 03:01:32 imagezza named[1872]: creating IPv4 interface venet0:1 failed; interface ignored
So i decided to run nmap and see the port 53 in action.
Here are result of it.

Code:
PORT     STATE SERVICE    VERSION
21/tcp   open  ftp        ProFTPD 1.3.1
22/tcp   open  ssh         (protocol 2.0)
53/tcp   open  tcpwrapped
80/tcp   open  http       Apache httpd 2.2.9 ((Debian) PHP/5.2.6-1+lenny8 with S                                                                             uhosin-Patch)
3306/tcp open  mysql      MySQL (Host blocked because of too many connections)
5901/tcp open  vnc        VNC (protocol 3.8)
6001/tcp open  X11         (access denied)
So as we cn see 53/tcp port is already open for another process "tcpwrapped"..

How can i change my bind9 to run on another port? I dont know "tcpwrapped" process. So how can i stop it or run it on another port?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 26th April 2010, 14:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Can you post the outputs of
Code:
netstat -tap
and
Code:
netstat -uap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 26th April 2010, 20:20
axtoxic107 axtoxic107 is offline
Junior Member
 
Join Date: Apr 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for ur input..

Here are stats of netstat -tap

Quote:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 29929/mysqld
tcp 0 0 localhost:submission *:* LISTEN 3810/sendmail: MTA:
tcp 0 0 *:5901 *:* LISTEN 12092/Xvnc4
tcp 0 0 *:www *:* LISTEN 3759/apache2
tcp 0 0 *:x11-1 *:* LISTEN 12092/Xvnc4
tcp 0 0 *:domain *:* LISTEN 5551/pdns_server-in
tcp 0 0 *:ssh *:* LISTEN 1547/sshd
tcp 0 0 localhost:smtp *:* LISTEN 3810/sendmail: MTA:
tcp 0 0 localhost:mysql localhost:37878 ESTABLISHED 29929/mysqld
tcp 0 0 localhost:mysql localhost:42115 ESTABLISHED 29929/mysqld
tcp 0 0 localhost:42098 localhost:mysql ESTABLISHED 5551/pdns_server-in
tcp 0 0 localhost:42099 localhost:mysql ESTABLISHED 5551/pdns_server-in
tcp 0 0 localhost:42097 localhost:mysql ESTABLISHED 5551/pdns_server-in
tcp 0 0 localhost:42115 localhost:mysql ESTABLISHED 5551/pdns_server-in
tcp 0 0 localhost:37878 localhost:mysql ESTABLISHED 5551/pdns_server-in
tcp 0 0 localhost:mysql localhost:42097 ESTABLISHED 29929/mysqld
tcp 0 0 localhost:mysql localhost:42098 ESTABLISHED 29929/mysqld
tcp 0 0 localhost:mysql localhost:42099 ESTABLISHED 29929/mysqld
tcp 0 0 imagezza.com:46983 vz23.ramhost.us:www ESTABLISHED 15397/epiphany-brow
tcp 0 456 imagezza.com:ssh 175.100.174.34:61891 ESTABLISHED 10152/0
tcp6 0 0 [::]:ftp [::]:* LISTEN 11659/proftpd: (acc
tcp6 0 0 [::]:ssh [::]:* LISTEN 1547/sshd

Netstat - uap

Quote:
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
udp 0 0 *:domain *:* 5551/pdns_server-in
udp6 0 0 [::]:talk [::]:* 1606/xinetd
udp6 0 0 [::]:ntalk [::]:* 1606/xinetd
Here in the above netstat -tap result,
29929/mysqld
tcp 0 0 imagezza.com:46983 vz23.ramhost.us:www ESTABLISHED

This line is confusing to me..ramhost.us is my old host, i create new server on burst.net..
Reply With Quote
  #4  
Old 26th April 2010, 21:08
dfed dfed is offline
Junior Member
 
Join Date: Apr 2010
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by axtoxic107 View Post
Thanks for ur input..

Here are stats of netstat -tap




Netstat - uap



Here in the above netstat -tap result,
29929/mysqld
tcp 0 0 imagezza.com:46983 vz23.ramhost.us:www ESTABLISHED

This line is confusing to me..ramhost.us is my old host, i create new server on burst.net..
So you're running pdns and bind together?
Reply With Quote
  #5  
Old 27th April 2010, 03:41
axtoxic107 axtoxic107 is offline
Junior Member
 
Join Date: Apr 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Actully i first install pdns but its not worked so i install bind and then trying..
Cant i run botht together, do i need to uninstall pdns first?
Reply With Quote
  #6  
Old 27th April 2010, 03:44
dfed dfed is offline
Junior Member
 
Join Date: Apr 2010
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

Code:
tcp 0 0 *:domain *:* LISTEN 5551/pdns_server-in
That means pdns is taking up the port on which bind wants to run.

One or the other. either uninstall bind and fix pdns or uninstall pdns.
Reply With Quote
  #7  
Old 27th April 2010, 17:41
axtoxic107 axtoxic107 is offline
Junior Member
 
Join Date: Apr 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks man...
I finally got the thing working.

Now my other problem is my sites are running very slow..Previously when Phpmyadmin was installed it was running fast but now its very very slow..

Can u help me here please?
What will be the reason for this slowness?
Reply With Quote
  #8  
Old 27th April 2010, 19:10
axtoxic107 axtoxic107 is offline
Junior Member
 
Join Date: Apr 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

can someone please explain this line
tcp 0 0 imagezza.com:46983 vz23.ramhost.us:www ESTABLISHED 15397/epiphany-brow

here ramhost.us is my previous host.
Why this new server is point mysql to that host??
Reply With Quote
  #9  
Old 27th April 2010, 19:30
axtoxic107 axtoxic107 is offline
Junior Member
 
Join Date: Apr 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i am trying my best here..
My latest nmap result
Quote:
Not shown: 1710 closed ports
PORT STATE SERVICE VERSION
21/tcp open ftp ProFTPD 1.3.1
22/tcp open ssh (protocol 2.0)
53/tcp open domain
80/tcp open http?
3306/tcp open mysql MySQL (Host blocked because of too many connections)
mysql open but the message "Host blocked because of too many connections" there must be something wrong in the server so it blocked it..

Where can i see the error log of mysql..I am using debian linux..

And one more result for ur reference - netstat -tap
Quote:
tcp 0 0 *:mysql *:* LISTEN 17616/mysqld
What does "bind-redirect 127.0.0.1" do? Right now in my my.cnf file that line is commented.

One more important thing, my phpmyadmin working well here..I have install mysql by following below tutorial
http://www.howtoforge.com/ubuntu_debian_lamp_server

Thanks
Reply With Quote
  #10  
Old 28th April 2010, 14:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

You can try to add something like
Code:
max_connections        = 100
to the [mysqld] section in /etc/mysql/my.cnf. Don't forget to restart MySQL afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Two FTP Issues: Change Port and Alerts jonwatson Installation/Configuration 3 13th February 2009 13:49
How to change Port 25 to different Port # happz Installation/Configuration 1 6th October 2008 14:42
Mail Question: installed smf forum on centos perfect server setup with ispconfig happz Installation/Configuration 7 22nd August 2008 13:15
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40


All times are GMT +2. The time now is 16:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.