Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd April 2010, 11:41
smet smet is offline
Junior Member
 
Join Date: Apr 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Question Creating sites with specific user as owner

Hi

I run ISPConfig a little different then expected, and I need sites to be created with a specific user as owner of the directories and files.

When creating a new site, ownership is set to "root" in some places, and client[id]/user[id] in other places.

How do I go about making the last once owned (user and group) by i.e. 'harry'?

What I need is for ISPConfig to create the sites as follows:

# ls -ald /var/www/clients/client0/web2/web/
drwx--x--- 4 harry harry 4096 Apr 22 09:25 /var/www/clients/client0/web0/web/

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 24th April 2010, 23:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,975
Thanks: 825
Thanked 5,367 Times in 4,214 Posts
 
Default

Thats not supported in ispconfig as ispconfig creates the website users for the sites, you might have to write your own apache config module if you want to change this.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Steps for creating users, sites etc jokke Developers' Forum 1 12th February 2009 23:31
creating user via remoting does not work AllanJ Installation/Configuration 9 29th April 2008 22:57
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48
ISPConfig stopped creating users, sites... Traxus Installation/Configuration 4 9th February 2006 10:00


All times are GMT +2. The time now is 14:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.