Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th April 2010, 19:33
jwlinux jwlinux is offline
Junior Member
 
Join Date: Mar 2010
Posts: 27
Thanks: 5
Thanked 2 Times in 2 Posts
Default Bug: Checking "SSL" does not enble SSL for the site

Hello,

I have ISPConfig 3.0.2 setup on Debian Lenny using the "Perfect setup" howto-forge docs (and I have upgraded it to 3.0.2.1).

I have a web site, working fine, it's on a secondary IP address and no other site is on that IP (and it is not marked as a name based vhost IP). It's working correctly.

We decided we needed to have an SSL on it so as the admin user, I sent to the site's settings, and checkd the box "SSL". Clicked save, and waited quite a while, but the apache config files have not changed - the site is not listening on 443, it's still set to :80 and there's no apache SSL Directives in the config file for this vhost.

I was able to generate the keys in the ISP config interface and it looks like they were made correctly. But the site is not configured to use them.

Isn't this a bug? What am I supposed to do to fix or work around this?
I can edit the vhost file by hand but I'm afraid that will break thing. Also, some of my clients don't have the technical skills to do manual configuration - I need them to be able to click the button and have it work.

Please advise.

Thanks,

JW
Reply With Quote
Sponsored Links
  #2  
Old 20th April 2010, 22:29
jwlinux jwlinux is offline
Junior Member
 
Join Date: Mar 2010
Posts: 27
Thanks: 5
Thanked 2 Times in 2 Posts
Default

I've done some testing and discovered that even a brand new site does not get configured in apache for SSL when the SSL box is checked from the beginning?

Am I missing something?

What is the correct way to setup an SSL website in ISPConfig 3?
Reply With Quote
  #3  
Old 25th April 2010, 10:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,383
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

Thats absolutly ok and not a bug. You just missed to create a ssl cert, without a ssl cert, the website can not be configured for ssl of course or apache will stop.

First, make sure that you selected a dedicated IP address for this website ind not * as SSl does not work with *. Then after you enabled ssl for the website, go to the ssl tab, enter the details for the ssl cert and select "create" as action. Then after 1 - 2 minutes, the website will be enabled for ssl.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 29th April 2010, 21:52
charlesrg charlesrg is offline
Junior Member
 
Join Date: Sep 2009
Posts: 14
Thanks: 2
Thanked 4 Times in 2 Posts
Default Same Problem Here

I'm using 3.0.2.1 and it's the same issue. It does not do anything checking the SSl option.
Create Certificate does create it, but it never changes the Vhost configuration to use the certificate file.
Reply With Quote
  #5  
Old 1st May 2010, 07:38
jwlinux jwlinux is offline
Junior Member
 
Join Date: Mar 2010
Posts: 27
Thanks: 5
Thanked 2 Times in 2 Posts
Default

Till: You said "You just missed to create a ssl cert, without a ssl cert, the website can not be configured for ssl of course or apache will stop."

Ah but I did make an ssl cert - I setup test sites and tried making (creating) the certs both before and after, and neither way works. Now that I have a cert made I can turn the SSL checkbox on and off and it makes no difference.

Till also said "First, make sure that you selected a dedicated IP address for this website ind not * as SSl does not work with *."

Yes, I did do that. It is a dedicated IP, it is setup properly on the host OS, it is setup ("added") in ISPconfig, and it it NOT marked as a NameBasedVirtualHost IP.

Till also said: "Then after you enabled ssl for the website, go to the ssl tab, enter the details for the ssl cert and select "create" as action. Then after 1 - 2 minutes, the website will be enabled for ssl."

But I have done exactly that, also I tried doing it in reverse order. Tried it multiple times, took it off and put it back on, tried a whole separate site on another IP, waited many minutes between each "change" and still SSL is never enabled.

charlesrg said:
"Same Problem Here
I'm using 3.0.2.1 and it's the same issue. It does not do anything checking the SSl option.
Create Certificate does create it, but it never changes the Vhost configuration to use the certificate file. "


Exactly, that's how it is for me.

Till - if there's some information I am missing that you want to know, please tell me. But I have done all the things you suggested, as best I can tell, and it is not working.

Thanks,

JW
Reply With Quote
  #6  
Old 1st May 2010, 08:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,383
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

There is a bug that appers if you select a ssl domain that is different from the website domain. See here for a fix:

http://www.howtoforge.com/forums/showthread.php?t=45526

or wait for the next ispconfig update.

As alternative, change the domain of the website so that it matches the domain that you selected as ssl domain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 4th May 2010, 03:31
lifeisboost lifeisboost is offline
Senior Member
 
Join Date: Feb 2006
Posts: 122
Thanks: 0
Thanked 2 Times in 2 Posts
 
Default

I am having the same issue. but my certs are the same as my site is named. I even did the fix for it. The issue is when i check the SSL box they vhost file is never changed it only still lists just port 80. Apache does not even have a port 443 listed for listening. any and all help is appreciated i need to get SSL going on this one site for the shopping cart.
Reply With Quote
Reply

Bookmarks

Tags
debian lenny, ispconfig 3.0.2.1, ssl certificate

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MyDNS Install Problems - rezilient Installation/Configuration 4 18th April 2013 21:48
rkhunter warnings esezako General 7 27th September 2011 07:28
Installation -- pcre_exec.c:403: internal compiler error: Segmentation fault zerman Installation/Configuration 2 23rd September 2008 23:58
Ubuntu 8.04 server edition ISPconfig installation error malinens Installation/Configuration 4 30th July 2008 07:30
Update php shajazzi Server Operation 6 6th April 2008 18:20


All times are GMT +2. The time now is 09:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.