Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th April 2010, 12:48
mnzava mnzava is offline
Member
 
Join Date: Aug 2007
Location: Dar es Salaam, Tanzania
Posts: 48
Thanks: 8
Thanked 0 Times in 0 Posts
Default maxmum upload limit doesnt take effect even after changes.

Hi,
I have been trying to change maximum upload limit on php.ini to no avail. Can somebody help me on how i can get rid of this setting issue?
Here is what i did. I changed settings in the following php.ini files and they are all the same:
/etc/php5/apache/php.ini
/etc/php5/cgi/php.ini
/etc/php5/cli/php.ini

settings i've added is as follows
memory_limit = 96M
post_max_size = 64M
upload_max_filesize = 64M

then i added the same limit to .htaccess file but when i refresh the files that i've created to see server setting, still i see upload_max_filesize is 2M.

Default configuration file according to my ispconfig 3 settings in CGI and is the same i see in phpinfo file. So the proper file is /etc/php5/cgi/php.ini(according to phpinfo)

Am using ISPConfig 3 on ubuntu 9.04.

Thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 7th April 2010, 09:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,397 Times in 4,241 Posts
Default

The file sthat you changed are ok. Have you restartet apache?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th April 2010, 10:00
mnzava mnzava is offline
Member
 
Join Date: Aug 2007
Location: Dar es Salaam, Tanzania
Posts: 48
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Dear Till,
I did every thing i.e restarting apache and even rebooting the machine but still memory limit does not change.

Also funny thing is that it shows MEMORY LIMIT = 128 while in my settings i set it to 96M. Is there something wrong with php in ubuntu?

Regards.
Reply With Quote
  #4  
Old 17th April 2010, 18:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please check your vhost configurations and your .htaccess file. Maybe you have different settings there.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 18th April 2010, 10:33
mnzava mnzava is offline
Member
 
Join Date: Aug 2007
Location: Dar es Salaam, Tanzania
Posts: 48
Thanks: 8
Thanked 0 Times in 0 Posts
 
Default

Thank you very much Till and Falko.

When falko mentioned vhost file then i decided to check other things apart from just upload limit configuration.

Then i decided to run this command to see if php package am using is properly compiled with fast cgi. Coz i started to think that may be fast-cgi is not working properly.

Then i run this command:

HTML Code:
php-cgi -v
Then i got what i was looking for with addition of the following ERROR msg

HTML Code:
PHP:  Error parsing /etc/php5/cgi/php.ini on line 222
Since vi doesn't show line numbers by default, i enabled line numbers with the following command. :set nu

After reaching that line i remembered that i did some security issues on the server before, but i made some errors on disable_functions

Code:
disable_functions = disable_functions = show_source, system, shell_exec, passthru, exec, phpinfo, popen, escapeshellarg, escapeshellcmd, proc_open
instead of

Code:
disable_functions = show_source, system, shell_exec, passthru, exec, phpinfo, popen, escapeshellarg, escapeshellcmd, proc_open
note on the first part disable_functions repeated twice.

Hope this will help someone else facing the same problem.

Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP Problems wabz Installation/Configuration 6 11th January 2010 18:51
ISPConfig3 Installed/But My Mail Client is rejecting addresses LinuxGuyMT Installation/Configuration 17 21st December 2009 10:35
Attacks on MTA dclardy Installation/Configuration 4 29th September 2009 16:50
Unable to receve email aberrio Server Operation 16 8th July 2009 10:26
slow download through webserver problem snewp Technical 14 9th May 2008 05:25


All times are GMT +2. The time now is 00:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.