Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 16th April 2010, 20:52
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 150 Times in 130 Posts
Default

Hans I get this when doing the "apt-get install clamav"
Quote:
host:/home/# apt-get install clamav
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
clamav: Depends: libclamav6 (>= 0.95.3+dfsg) but it is not going to be installed
Depends: libtommath0 but it is not installable
E: Broken packages
Dong this: apt-get install libclamav6
gives me this:
Quote:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libclamav6: Depends: libtommath0 but it is not installable
E: Broken packages
__________________
Never execute code written on a Friday or a Monday.

Last edited by edge; 16th April 2010 at 20:54.
Reply With Quote
Sponsored Links
  #12  
Old 16th April 2010, 21:08
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 150 Times in 130 Posts
Default

Okay.. Got it working.
Problem with my system was that I could not use the "volatile.debian.org lenny/volatile/main Packages" as it was duplicated.
Quote:
duplicate sources.list entry http://volatile.debian.org lenny/volatile/main Packages (/var/lib/apt/lists/volatile.debian.org_debian-volatile_dists_lenny_volatile_main_binary-i386_Packages)
Damn.. I lost a lot of email as I also did a "postsuper -d ALL"

Greatings from Scotland this time :-)
__________________
Never execute code written on a Friday or a Monday.

Last edited by edge; 24th April 2010 at 11:04.
Reply With Quote
  #13  
Old 16th April 2010, 21:11
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Thumbs up

@Edge, good to hear you did it!
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
The Following User Says Thank You to Hans For This Useful Post:
edge (16th April 2010)
  #14  
Old 17th April 2010, 00:53
binaryrogue binaryrogue is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 5
Thanked 0 Times in 0 Posts
Default

I'm also running Fedora 10 and my mail flow just stopped regarding this issue. Any tips regarding upgrading clamav will be very helpful. In the meantime, I just commented out:

#content_filter = amavis:[127.0.0.1]:10024

in my main.cf file in the meantime since I have another spam/virus filter in front as first touch.

**Better workaround for Fedora 10 - You can still keep using amavisd running to scan for spam/viruses but you won't be able to get the latest antivirus definitions. If you have a backup of daily.cld from two days ago... replace it with the the current one "/var/lib/clamav/daily.cld". Then disable the freshclam updates from "/etc/cron.d/clamav-update".

I still would like know if anyone running Fedora 10 can get clamav upgraded to 0.95 or 0.96.

Last edited by binaryrogue; 17th April 2010 at 02:53.
Reply With Quote
  #15  
Old 17th April 2010, 16:37
mode mode is offline
Junior Member
 
Join Date: May 2008
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I'm facing on the same problem on my Fedora 10 as well. Help !
Reply With Quote
  #16  
Old 18th April 2010, 23:15
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 478
Thanks: 78
Thanked 39 Times in 33 Posts
Default

Quote:
Originally Posted by Hans View Post
@Edge,
You must do this:

add the line deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free to your /etc/apt/sources.list

After that execute:

apt-get update
apt-get install clamav
apt-get upgrade
/etc/init.d/amavis restart
postsuper -r ALL
I'm a bit confused, SamTzu didn't include the line apt-get install clamav. I already have it installed, should I include this line?
Reply With Quote
  #17  
Old 18th April 2010, 23:31
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 150 Times in 130 Posts
Default

Yes you will need to do this as you need to install the "new" clamav from "http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free"
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #18  
Old 19th April 2010, 04:43
spikes spikes is offline
Member
 
Join Date: Sep 2009
Posts: 45
Thanks: 6
Thanked 2 Times in 1 Post
Default

After I have done the upgrade and login to ispconfig. I still see this:

warning:
Your virus protection is OUTDATED! [More...]

Received signal: wake up
ClamAV update process started at Mon Apr 19 04:25:22 2010
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.94.2 Recommended version: 0.96
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cld is up to date (version: 52, sigs: 704727, f-level: 44, builder: sven)
daily.cld is up to date (version: 10756, sigs: 52433, f-level: 51, builder: guitar)

I thought it's upgraded now? Do I need to un-install the old ver manually and how?

Reading package lists... Done
server1:~# apt-get install clamav
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
sharutils
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libclamav6 libtommath0
Suggested packages:
libclamunrar6
The following NEW packages will be installed:
libclamav6 libtommath0
The following packages will be upgraded:
clamav
1 upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
Need to get 884kB of archives.
After this operation, 1315kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ftp.nz.debian.org lenny/main libtommath0 0.39-3 [52.6kB]
Get:2 http://volatile.debian.org lenny/volatile/main libclamav6 0.95.3+dfsg-1~vo
latile1 [560kB]
Get:3 http://volatile.debian.org lenny/volatile/main clamav 0.95.3+dfsg-1~volati
le1 [271kB]
Fetched 884kB in 6s (143kB/s)
Reading changelogs... Done
Selecting previously deselected package libtommath0.
(Reading database ... 39849 files and directories currently installed.)
Unpacking libtommath0 (from .../libtommath0_0.39-3_i386.deb) ...
Selecting previously deselected package libclamav6.
Unpacking libclamav6 (from .../libclamav6_0.95.3+dfsg-1~volatile1_i386.deb) ...
Preparing to replace clamav 0.94.dfsg.2-1lenny2 (using .../clamav_0.95.3+dfsg-1~
volatile1_i386.deb) ...
Unpacking replacement clamav ...
Processing triggers for man-db ...
Setting up libtommath0 (0.39-3) ...
Setting up libclamav6 (0.95.3+dfsg-1~volatile1) ...
Setting up clamav (0.95.3+dfsg-1~volatile1) ...
server1:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
clamav-base clamav-daemon clamav-freshclam
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 24.7MB of archives.
After this operation, 4874kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://volatile.debian.org lenny/volatile/main clamav-freshclam 0.95.3+dfs
g-1~volatile1 [281kB]
Get:2 http://volatile.debian.org lenny/volatile/main clamav-daemon 0.95.3+dfsg-1
~volatile1 [364kB]
Get:3 http://volatile.debian.org lenny/volatile/main clamav-base 0.95.3+dfsg-1~v
olatile1 [24.0MB]
Fetched 24.7MB in 2min35s (158kB/s)
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 39868 files and directories currently installed.)
Preparing to replace clamav-freshclam 0.94.dfsg.2-1lenny2 (using .../clamav-fres
hclam_0.95.3+dfsg-1~volatile1_i386.deb) ...
Stopping ClamAV virus database updater: freshclam.
Unpacking replacement clamav-freshclam ...
Preparing to replace clamav-daemon 0.94.dfsg.2-1lenny2 (using .../clamav-daemon_
0.95.3+dfsg-1~volatile1_i386.deb) ...
Stopping ClamAV daemon: clamd.
Unpacking replacement clamav-daemon ...
Preparing to replace clamav-base 0.94.dfsg.2-1lenny2 (using .../clamav-base_0.95
.3+dfsg-1~volatile1_all.deb) ...
Unpacking replacement clamav-base ...
Processing triggers for man-db ...
Setting up clamav-base (0.95.3+dfsg-1~volatile1) ...
Replacing config file /etc/clamav/clamd.conf with new version
Setting up clamav-freshclam (0.95.3+dfsg-1~volatile1) ...
Installing new version of config file /etc/init.d/clamav-freshclam ...
Replacing config file /etc/clamav/freshclam.conf with new version
Starting ClamAV virus database updater: freshclam.
Setting up clamav-daemon (0.95.3+dfsg-1~volatile1) ...
Installing new version of config file /etc/init.d/clamav-daemon ...
Starting ClamAV daemon: clamd LibClamAV Warning: *******************************
****************************
LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ************************************************** *********
.
Reply With Quote
  #19  
Old 19th April 2010, 06:02
spikes spikes is offline
Member
 
Join Date: Sep 2009
Posts: 45
Thanks: 6
Thanked 2 Times in 1 Post
Default

I see. Thank you.

WARNING: Local version: 0.95.3 Recommended version: 0.96
Reply With Quote
  #20  
Old 19th April 2010, 06:03
cyberw cyberw is offline
Junior Member
 
Join Date: Sep 2009
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
 
Default clamav 0.96 FC10 download update problem

Hello Team,

I too am having the clamav 0.94 FC10 problem. I am unable to locate an update using yum, and am unsure how to obtain from another location that will suit this installation.

I have a malformed DB according to clamscan, and all updates continue to re-install 0.94.

Live server, no mail currently. What do you need in order to assist me with this people?

TIA, Cyberw
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sql ledger using forum.. yurtboy1 General 19 25th December 2010 21:08
Amavis end of life problem @ debian 5 voltron81 Installation/Configuration 4 16th April 2010 16:10
ISPConfig 2.x End Of Life? rezilient General 2 27th January 2009 15:38
Clamav 0.94 is out frankihk Feature Requests 6 1st October 2008 14:34
UebiMiau login puntjuh Installation/Configuration 13 14th March 2006 18:24


All times are GMT +2. The time now is 12:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.