Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th April 2010, 10:10
vtapas vtapas is offline
Member
 
Join Date: Apr 2010
Posts: 51
Thanks: 1
Thanked 0 Times in 0 Posts
Default outgoing registration email is not going I running webserver server behind a proxy

Hi,
I have a small problem to which I do not have a clue.
I am having a linux router which has a public IP and have hosted a few websites from computers which are on lan.
The scenario is like this

Code:
 router--->  www.myserver.com         internal LAN ip 192.168.0.1 

  domu1----->www.myserver.com/domu1    on internal LAN 192.168.0.11

  domu2----->www.myserver.com/domu2    on internal LAN 192.168.0.12

  domu3----->www.myserver.com/domu3    on internal LAN 192.168.0.13
 
  domu4----->www.myserver.com/domu4    on internal LAN 192.168.0.14

Now the sites www.myserver.com/domu1 to domu4 all have registration pages.
I have drupal as web development platform.These sites can be accessed on internet with only home pages.
When a user tries to create a new account on any of them
say for example www.myserver.com/domu1

the outgoing registration email is not going.
What steps should I do to check it ?
How can it be made possible?
To my mind it comes I should setup SMTP and do some forwarding routing with ports etc but I am not sure so need suggestions.
I googled about SMTP configuration and came across that Drupal does not seems to have good SMTP configuration http://ubuntuforums.org/archive/index.php/t-855064.html

Last edited by vtapas; 16th April 2010 at 11:59.
Reply With Quote
Sponsored Links
  #2  
Old 17th April 2010, 19:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Do you have a dynamic IP address? Then you're most likely blacklisted, and you should set up relaying: http://www.howtoforge.com/postfix_re...her_mailserver

You can check if you're blacklisted: http://mxtoolbox.com/blacklists.aspx
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th April 2010, 19:10
vtapas vtapas is offline
Member
 
Join Date: Apr 2010
Posts: 51
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

No I have a static IP.
In the webpage you mentioned I see all as green what does that mean.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 23:08
User constantly loggin into mail? bswinnerton Installation/Configuration 2 24th March 2008 01:12
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 17:30
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30
Can the squirrelmail webserver different then email server? ejkeebler Server Operation 2 4th November 2005 20:28


All times are GMT +2. The time now is 08:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.