Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th April 2010, 17:07
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 0 Times in 0 Posts
Default Upgrade from 34 -> 35 went horribly wrong

Greetings,

I upgraded my version of ISPConfig from 2.2.34 to 2.2.35 and now my apache wont run, my ISPconfig panel wont run. When I try, it complains about certificates not in existence.

I decided to rerun the upgrade, simply because I know I received an error, but everything completed seemingly successfully. When I rebooted, I lost the error. Now when I run it I get:

Code:
Checking the syntax of the httpd.conf...
Syntax error on line 144 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
SSLCertificateChainFile: file '/root/ispconfig/httpd/conf/ssl.crt/sub.class2.server.ca.crt' does not exist or is empty
ERROR: The syntax of your httpd.conf is not ok! Please correct the error. The installation routine stops here!
root@dethlefsmoreno:~/upgrade_ispconfig/install_ispconfig#
Checking that directory (/root/ispconfig) I only have the following directory structure:
/
-root/
--ispconfig/
---isp/
----conf/
-----customized_templates/

And that directory is empty. I'm not sure what I did wrong, and where to begin, but I would like to maintain my websites and get this back and running.

System versions:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu 9.10"

root@dethlefsmoreno:~/ispconfig/isp/conf/customized_templates# gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.4.1-4ubuntu9' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --program-suffix=-4.4 --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i486 --with-tune=generic --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu9)

Any help, I'll appreciate.

Kevin
Reply With Quote
Sponsored Links
  #2  
Old 15th April 2010, 18:15
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 0 Times in 0 Posts
Default

In my impatience, I backed everything up as far as the web directories and the mysql DB's....

Right now I'm running the install again after removing the ispconfig folder in /root.

Seems to be going OK, but I'll post if anything goes wrong. Worse case scenario, I reinstall ubuntu (really not that big of a deal).

Thanks,
Kevin
Reply With Quote
  #3  
Old 15th April 2010, 20:55
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Just to post for future users, I found that reinstalling worked well for me. It kept all my settings, I had to restore a vhost configuration file back to previous and I don't know if ISPConfig will overwrite that, but the site works, the control panel works and I had to redo my ssl certificates and configuration for ISPConfig, but everything is secured.

Thanks to those who are reading with intent to help, but I seem to have it under control.
Reply With Quote
  #4  
Old 15th April 2010, 21:31
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,628
Thanks: 793
Thanked 4,998 Times in 3,909 Posts
Default

The error occured because you had put a ssl chain cert into a subfolder of the ispconfig installation, but apache gets updated and so the folders get replaced during the update so that your file was missing then. To avaoid this, do not store any custom files in the ispconfig source directorys. If you put the chain cert in e.g. /etc/ssl, you will not get a problem.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
demortes (15th April 2010)
  #5  
Old 15th April 2010, 21:44
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 0 Times in 0 Posts
 
Default

That's a good idea. That's why you make good software, and I just put holes into them.
Reply With Quote
Reply

Bookmarks

Tags
2.2.35, ubuntu 9.10, upgrade

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Post Etch->Lenny upgrade question jdkullmann Installation/Configuration 1 8th February 2010 09:48
wrong kernel after upgrade from etch to lenny vogelor Installation/Configuration 1 24th June 2009 17:49
debian upgrade broken.. apt-get stuck guthrie Installation/Configuration 3 31st March 2009 04:29
Upgrade went wrong: ISPConfig gone djkoelkast Installation/Configuration 5 21st February 2008 17:26
Installation Troubles bswinnerton Installation/Configuration 4 29th July 2007 16:56


All times are GMT +2. The time now is 09:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.