Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th April 2010, 06:51
JamesD JamesD is offline
Junior Member
 
Join Date: Apr 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default SSL install: cannot find new certificate

Hi,

I'm bumping my head into the wall. Here is my case:

1) I have two co-loc servers installed with ISPConfig (not sure about the version now but I installed them in 2007). Let me call them A and B.

2) Server A has multiple IP addresses so all the virtual servers are IP-based;
Server B has only 1 IP address so all the virtual servers are Name-based;

3) Now I started installing SSL certificate for my virtual servers.

-- For A: it works like a charm and I have my servers configured with SSL in one minute.

-- For B: I knew it's not possible (well before Apache 2.2.8, it may work with some hack) to enable SSL on all Name-based virtual hosts. But I only want to enable SSL on **one** virtual host.
The problem is: no matter how I configured the SSL in apache httpd.conf and Vhost conf files, this virtual host *always* returns an invalid SSL certificate which I created years ago when installing ISPconfig.

It never returns the new-certificate I just installed. I have searched through all the configuration files but I cannot find where and how it still refers to old certificate files.

4) In the meantime, I modified ISPConfig's conf files, and ISPconfig can now be accessed with new SSL without any problem.

5) This may be a little long, but can someone help me on to make one of my virtual server on B to work with new SSL certificate?

Thanks a lot in advance.

-- James

Last edited by JamesD; 14th April 2010 at 06:56.
Reply With Quote
Sponsored Links
  #2  
Old 14th April 2010, 08:05
JamesD JamesD is offline
Junior Member
 
Join Date: Apr 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Fixed

Ok, on Server B, since it's a single IP address server, I also need to update /etc/httpd/conf.d/ssl.conf with my new certificate to make it work.

Cheers,

-- JamesD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my postfix is hacked? bzzik Server Operation 21 15th July 2009 15:13
Creating SSL crashed apache punto Installation/Configuration 8 22nd June 2009 09:00
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 11:37
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 15:42
ssl Certificate Invalid simplyworks Installation/Configuration 8 16th August 2006 17:44


All times are GMT +2. The time now is 09:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.