Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th April 2010, 16:29
sfang125 sfang125 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default FTP Login Problems

Hello all. I am using ISPConfig 3, and I am having problems logging into my websites respective FTP areas to insert my already existing websites. I have used FTP://, FTPS://, and even inserted th usernames in the ftp://username configuration. I'm not sure what I am doing wrong here, but I will say that this is the first time I have used this software. Can someone shine some light on my situation please?!?
Reply With Quote
Sponsored Links
  #2  
Old 8th April 2010, 11:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

Please enable verbose logging in pure-ftpd and post the error messages that you get:

http://www.faqforge.com/linux/contro...-debian-linux/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th April 2010, 05:38
sfang125 sfang125 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default pureFTPd Enabled results

Here are the results as per the website you requested me to follow. I hope that I did it right... but it seems that there is nothing in the syslog that says anythign about pureFTPd:

Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -O clf:/var/log/pure-ftpd/transfer.log -E -b -A -B
root@ns1:/home/marcus# tail -n 100 /var/log/syslog
Apr 8 23:16:29 ns1 amavis[2195]: Internal decoder for .zip
Apr 8 23:16:29 ns1 amavis[2195]: No decoder for .7z tried: 7zr, 7za, 7z
Apr 8 23:16:29 ns1 amavis[2195]: No decoder for .rar tried: unrar-free
Apr 8 23:16:29 ns1 amavis[2195]: Found decoder for .arj at /usr/bin/arj
Apr 8 23:16:29 ns1 amavis[2195]: Found decoder for .arc at /usr/bin/nomarch
Apr 8 23:16:29 ns1 amavis[2195]: Found decoder for .zoo at /usr/bin/zoo
Apr 8 23:16:29 ns1 amavis[2195]: No decoder for .lha
Apr 8 23:16:29 ns1 amavis[2195]: No decoder for .doc tried: ripole
Apr 8 23:16:29 ns1 amavis[2195]: Found decoder for .cab at /usr/bin/cabextract
Apr 8 23:16:29 ns1 amavis[2195]: No decoder for .tnef
Apr 8 23:16:29 ns1 amavis[2195]: Internal decoder for .tnef
Apr 8 23:16:29 ns1 amavis[2195]: Found decoder for .exe at /usr/bin/arj
Apr 8 23:16:29 ns1 amavis[2195]: Using primary internal av scanner code for ClamAV-clamd
Apr 8 23:16:29 ns1 amavis[2195]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
Apr 8 23:16:30 ns1 amavis[2195]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.34, libdb 4.6
Apr 8 23:16:31 ns1 mysqld_safe[2268]: started
Apr 8 23:16:31 ns1 mysqld[2272]: 100408 23:16:31 InnoDB: Started; log sequence number 0 43665
Apr 8 23:16:31 ns1 mysqld[2272]: 100408 23:16:31 [Note] /usr/sbin/mysqld: ready for connections.
Apr 8 23:16:31 ns1 mysqld[2272]: Version: '5.0.75-0ubuntu10.3' socket: '/var/run/mysqld/mysqld.sock' port: 3306 (Ubuntu)
Apr 8 23:16:32 ns1 /etc/mysql/debian-start[2319]: Upgrading MySQL tables if necessary.
Apr 8 23:16:33 ns1 /etc/mysql/debian-start[2324]: Looking for 'mysql' as: /usr/bin/mysql
Apr 8 23:16:33 ns1 /etc/mysql/debian-start[2324]: Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
Apr 8 23:16:33 ns1 /etc/mysql/debian-start[2324]: This installation of MySQL is already upgraded to 5.0.75, use --force if you still need to run mysql_upgrade
Apr 8 23:16:33 ns1 /etc/mysql/debian-start[2334]: Checking for insecure root accounts.
Apr 8 23:16:33 ns1 /etc/mysql/debian-start[2338]: Triggering myisam-recover for all MyISAM tables
Apr 8 23:16:34 ns1 spamd[2331]: logger: removing stderr method
Apr 8 23:16:34 ns1 kernel: [ 29.024728] ip_tables: (C) 2000-2006 Netfilter Core Team
Apr 8 23:16:35 ns1 kernel: [ 29.104499] nf_conntrack version 0.5.0 (8055 buckets, 32220 max)
Apr 8 23:16:35 ns1 kernel: [ 29.104784] CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
Apr 8 23:16:35 ns1 kernel: [ 29.104789] nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or
Apr 8 23:16:35 ns1 kernel: [ 29.104792] sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
Apr 8 23:16:42 ns1 authdaemond: modules="authmysql", daemons=5
Apr 8 23:16:42 ns1 authdaemond: Installing libauthmysql
Apr 8 23:16:42 ns1 authdaemond: Installation complete: authmysql
Apr 8 23:16:43 ns1 mydns[2989]: mydns 1.2.8.27 started Thu Apr 8 23:16:43 2010 (listening on 3 addresses)
Apr 8 23:16:44 ns1 postfix/master[3062]: daemon started -- version 2.5.5, configuration /etc/postfix
Apr 8 23:16:44 ns1 kernel: [ 38.689824] warning: `pure-ftpd-mysql' uses 32-bit capabilities (legacy support in use)
Apr 8 23:16:45 ns1 /usr/sbin/cron[3201]: (CRON) INFO (pidfile fd = 3)
Apr 8 23:16:45 ns1 /usr/sbin/cron[3202]: (CRON) STARTUP (fork ok)
Apr 8 23:16:46 ns1 /usr/sbin/cron[3202]: (CRON) INFO (Running @reboot jobs)
Apr 8 23:16:49 ns1 spamd[2380]: spamd: server started on port 783/tcp (running version 3.2.5)
Apr 8 23:16:49 ns1 spamd[2380]: spamd: server pid: 2380
Apr 8 23:16:49 ns1 spamd[2380]: spamd: server successfully spawned child process, pid 3233
Apr 8 23:16:49 ns1 spamd[2380]: spamd: server successfully spawned child process, pid 3234
Apr 8 23:16:49 ns1 spamd[2380]: prefork: child states: II
Apr 8 23:17:01 ns1 console-kit-daemon[3276]: WARNING: cannot initialize libpolkit, some functionality will not be available
Apr 8 23:17:01 ns1 /USR/SBIN/CRON[3352]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:17:01 ns1 /USR/SBIN/CRON[3354]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Apr 8 23:18:01 ns1 /USR/SBIN/CRON[3376]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:19:01 ns1 /USR/SBIN/CRON[3393]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:20:01 ns1 /USR/SBIN/CRON[3424]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:20:01 ns1 /USR/SBIN/CRON[3427]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
Apr 8 23:20:01 ns1 /USR/SBIN/CRON[3428]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:20:02 ns1 pure-ftpd: (?@localhost) [INFO] New connection from localhost
Apr 8 23:20:02 ns1 pure-ftpd: (?@localhost) [INFO] Logout.
Apr 8 23:20:02 ns1 mydns[2990]: read_tcp_length: no data for fd 8: ::1: Client closed TCP connection
Apr 8 23:20:02 ns1 pop3d: Connection, ip=[::1]
Apr 8 23:20:02 ns1 pop3d: Disconnected, ip=[::1]
Apr 8 23:20:02 ns1 imapd: Connection, ip=[::1]
Apr 8 23:20:02 ns1 imapd: Disconnected, ip=[::1], time=0
Apr 8 23:20:03 ns1 postfix/smtpd[3452]: connect from localhost.localdomain[127.0.0.1]
Apr 8 23:20:03 ns1 postfix/smtpd[3452]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Apr 8 23:20:03 ns1 postfix/smtpd[3452]: disconnect from localhost.localdomain[127.0.0.1]
Apr 8 23:20:36 ns1 ntpd[1731]: synchronized to 91.189.94.4, stratum 2
Apr 8 23:20:36 ns1 ntpd[1731]: kernel time sync status change 0001
Apr 8 23:21:01 ns1 /USR/SBIN/CRON[3559]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:22:01 ns1 /USR/SBIN/CRON[3576]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:23:01 ns1 /USR/SBIN/CRON[3593]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:24:01 ns1 /USR/SBIN/CRON[3610]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:25:01 ns1 /USR/SBIN/CRON[3634]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:25:01 ns1 /USR/SBIN/CRON[3636]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:25:01 ns1 pure-ftpd: (?@localhost) [INFO] New connection from localhost
Apr 8 23:25:01 ns1 pure-ftpd: (?@localhost) [INFO] Logout.
Apr 8 23:25:01 ns1 pop3d: Connection, ip=[::1]
Apr 8 23:25:01 ns1 pop3d: Disconnected, ip=[::1]
Apr 8 23:25:01 ns1 imapd: Connection, ip=[::1]
Apr 8 23:25:01 ns1 imapd: Disconnected, ip=[::1], time=0
Apr 8 23:25:01 ns1 postfix/smtpd[3649]: connect from localhost.localdomain[127.0.0.1]
Apr 8 23:25:01 ns1 postfix/smtpd[3649]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Apr 8 23:25:01 ns1 postfix/smtpd[3649]: disconnect from localhost.localdomain[127.0.0.1]
Apr 8 23:26:01 ns1 /USR/SBIN/CRON[3685]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:27:01 ns1 /USR/SBIN/CRON[3702]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:28:01 ns1 /USR/SBIN/CRON[3719]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:29:02 ns1 /USR/SBIN/CRON[3736]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:30:01 ns1 /USR/SBIN/CRON[3774]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:30:01 ns1 /USR/SBIN/CRON[3777]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:30:01 ns1 /USR/SBIN/CRON[3779]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
Apr 8 23:30:01 ns1 pure-ftpd: (?@localhost) [INFO] New connection from localhost
Apr 8 23:30:01 ns1 pure-ftpd: (?@localhost) [INFO] Logout.
Apr 8 23:30:01 ns1 pop3d: Connection, ip=[::1]
Apr 8 23:30:01 ns1 pop3d: Disconnected, ip=[::1]
Apr 8 23:30:01 ns1 imapd: Connection, ip=[::1]
Apr 8 23:30:01 ns1 imapd: Disconnected, ip=[::1], time=0
Apr 8 23:30:01 ns1 postfix/smtpd[3800]: connect from localhost.localdomain[127.0.0.1]
Apr 8 23:30:01 ns1 postfix/smtpd[3800]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Apr 8 23:30:01 ns1 postfix/smtpd[3800]: disconnect from localhost.localdomain[127.0.0.1]
Apr 8 23:31:01 ns1 /USR/SBIN/CRON[3907]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:32:01 ns1 /USR/SBIN/CRON[3924]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:33:01 ns1 /USR/SBIN/CRON[3943]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Apr 8 23:34:01 ns1 /USR/SBIN/CRON[4007]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Reply With Quote
  #4  
Old 12th April 2010, 17:36
sfang125 sfang125 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Still having problems...

I am new to ISPConfig all together, and am still having FTP issues... Can someone please help me out? At most tell me how the format of the login should go (see original post). I'd appreciate all help I could get.
Reply With Quote
  #5  
Old 12th April 2010, 18:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

The log output above does not contain a FTP login attempt from a FTP user. Please try to login to pure-ftpd with a ftp client and then post the pure-ftpd lines that got added by this attempt in the log file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 12th April 2010, 19:10
sfang125 sfang125 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Just rteied to login via PSFTP

Ok. Here's the output from an attempt that I just made. It seems that it's not recognising the username that I have created in ISPConfig3. This is where it gets blurry to me. I tried to login through "PSFTP" (Putty type thing), and it lets me login with my system login, but not the accounts that I made with ISPConfig. What's going on here?

Apr 12 13:05:02 ns1 pure-ftpd: (?@localhost) [INFO] New connection from localhost
Apr 12 13:05:02 ns1 pure-ftpd: (?@localhost) [INFO] Logout.
Apr 12 13:05:02 ns1 pop3d: Connection, ip=[::1]
Apr 12 13:05:02 ns1 pop3d: Disconnected, ip=[::1]
Apr 12 13:05:02 ns1 imapd: Connection, ip=[::1]
Apr 12 13:05:02 ns1 imapd: Disconnected, ip=[::1], time=0
Apr 12 13:05:02 ns1 postfix/smtpd[4324]: connect from localhost.localdomain[127.0.0.1]
Apr 12 13:05:02 ns1 postfix/smtpd[4324]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Apr 12 13:05:02 ns1 postfix/smtpd[4324]: disconnect from localhost.localdomain[127.0.0.1]
Reply With Quote
  #7  
Old 12th April 2010, 19:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

The above login line is not from your login attempt. The line is from the ispconfig system check which checks all services every 5 minutes.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 12th April 2010, 20:56
sfang125 sfang125 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Red face

Ok. Well, do I get the output from syslog as the tutorial that you linked to about enabling verbose mode says, or do I get it from somewhere else? I a little confused... I don't know where to find things in my system all the time, as syslog is usually where I find all my problems.... I'm still learning my way around!
Reply With Quote
  #9  
Old 12th April 2010, 20:57
sfang125 sfang125 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is using proftp an option in ISPConfig3? I never had any problems with that one!
Reply With Quote
  #10  
Old 12th April 2010, 22:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
 
Default

Quote:
Originally Posted by sfang125 View Post
Ok. Well, do I get the output from syslog as the tutorial that you linked to about enabling verbose mode says, or do I get it from somewhere else? I a little confused... I don't know where to find things in my system all the time, as syslog is usually where I find all my problems.... I'm still learning my way around!
You look at the correct logfile as it contains the system checks for pure-ftpd. So pure-ftpd is running and working fine and also logging correctly.

Your problem is that you do not connect to this server with FTP, you seem to connect to a different server. Otherwise the login attemps would show up in the syslog. Please try to use the IP address of your server in the FTP client and not a domain name or the server hostname. You can also try to use passive and active FTP mode and make sure that you have no firewall started on the server.

Quote:
Is using proftp an option in ISPConfig3? I never had any problems with that one!
No. Proftpd is not supported by ispconfig and it would not solve your problem as the ftp daemon is not the source of the problem.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
squirrelmail and postfix witoszek General 12 1st December 2009 18:07
Postfix can't received email from exterior astra2000 Server Operation 5 17th October 2009 23:26
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 19:38
ftp problems tgansert Installation/Configuration 20 27th May 2006 19:06
Website users? ctroyp General 25 6th January 2006 18:02


All times are GMT +2. The time now is 09:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.