Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th April 2010, 03:58
idsinc idsinc is offline
Member
 
Join Date: Feb 2010
Posts: 56
Thanks: 14
Thanked 0 Times in 0 Posts
Default perfect-server-centos-5.3-x86_64-ispconfig-3

Location:

HTML Code:
http://www.howtoforge.net/perfect-server-centos-5.3-x86_64-ispconfig-3-p4
I have inserted my comments in blue below:
-------------------------------------------------------------------------
Trouble area from page 4:

Now (still in /tmp) we can build courier-authlib:

sudo rpmbuild -ta courier-authlib-0.62.2.tar.bz2
before typing this command, it is in [compileuser@server tmp]$
after I enter the command, it asks for a password:
I enter the password for compileuser, and the response is:

"compileuser is not in the sudoer file. This incident will be reported. You have new mail in /var/spool/mail/root"

When I type ls -l at [compileuser@server tmp]$ i find the listing below, but I dont find it at [compileuser@server x86_64]$

After the build process, the rpm packages can be found in $HOME/rpm/RPMS/x86_64 ($HOME/rpm/RPMS/i386 if you are on an i386 system):

cd $HOME/rpm/RPMS/x86_64

The command

ls -l

shows you the available rpm packages:

[compileuser@server1 x86_64]$ ls -l I do not get this result.
total 608
-rw-r--r-- 1 root root 139745 May 25 14:52 courier-authlib-0.62.2-1.x86_64.rpm
-rw-r--r-- 1 root root 328419 May 25 14:52 courier-authlib-debuginfo-0.62.2-1.x86_64.rpm
-rw-r--r-- 1 root root 35322 May 25 14:52 courier-authlib-devel-0.62.2-1.x86_64.rpm
-rw-r--r-- 1 root root 18310 May 25 14:52 courier-authlib-ldap-0.62.2-1.x86_64.rpm
-rw-r--r-- 1 root root 14501 May 25 14:52 courier-authlib-mysql-0.62.2-1.x86_64.rpm
-rw-r--r-- 1 root root 13714 May 25 14:52 courier-authlib-pgsql-0.62.2-1.x86_64.rpm
-rw-r--r-- 1 root root 8358 May 25 14:52 courier-authlib-pipe-0.62.2-1.x86_64.rpm
-rw-r--r-- 1 root root 35287 May 25 14:52 courier-authlib-userdb-0.62.2-1.x86_64.rpm
[compileuser@server1 x86_64]$
------------------------------------------------------------------------------------------
what am I missing?
Reply With Quote
Sponsored Links
  #2  
Old 13th April 2010, 08:10
Ghostdare Ghostdare is offline
Senior Member
 
Join Date: Aug 2009
Location: Europe - Romania - Bucharest
Posts: 146
Thanks: 10
Thanked 22 Times in 22 Posts
Default

Did you follow the exact steps by adding "compileuser" to your sistem and adding him to sudoers with "visudo"? Maybee you are not so familiar with vi and changes to sudoers file are not changed at all.
Reply With Quote
  #3  
Old 13th April 2010, 15:10
idsinc idsinc is offline
Member
 
Join Date: Feb 2010
Posts: 56
Thanks: 14
Thanked 0 Times in 0 Posts
Default perfect-server-centos-5.3-x86_64-ispconfig-3

oh... I think I entered vi sudo instead of visudo... thanx much
Reply With Quote
  #4  
Old 13th April 2010, 23:34
idsinc idsinc is offline
Member
 
Join Date: Feb 2010
Posts: 56
Thanks: 14
Thanked 0 Times in 0 Posts
Default perfect-server-centos-5.3-x86_64-ispconfig-3

Still on page 4..

11 Apply Quota Patch To Postfix
We have to get the Postfix source rpm, patch it with the quota patch, build a new Postfix rpm package and install it.

cd /usr/src

HTML Code:
wget http://ftp-stud.fht-esslingen.de/pub/Mirrors/centos/5.3/os/SRPMS/postfix-2.3.3-2.1.el5_2.src.rpm
rpm -ivh postfix-2.3.3-2.1.el5_2.src.rpm

when I type this in, my response is

Resolving ftp-stud.fht-esslinen.de 192.143.116.10
Connectiing to ftp-stud.fht-esslinen.de |192.143.116.10|:80 connected
HTTP request sent, awaiting response... 404 Not Found
2010-04-13 15:35:19 ERROR 404 Not Found


I tried a different place and got:

HTML Code:
wget http://mirrors.racspace.com/pub/CentOS/5.3/os/SRPMS/postfix-2.3.3-2.1.el5_2.src.rpm
rpm -ivh postfix-2.3.3-2.1.el5_2.src.rpm

Resolving mirror.rackspace.com 72.4.123.180
Connectiing to mirror.rackspace.com |72.4.123.180|:80 connected
HTTP request sent, awaiting response... 404 Not Found
2010-04-13 15:54:40 ERROR 404 Not Found


What does this message mean? Thanx again...

Last edited by idsinc; 13th April 2010 at 23:37.
Reply With Quote
  #5  
Old 14th April 2010, 07:47
Ghostdare Ghostdare is offline
Senior Member
 
Join Date: Aug 2009
Location: Europe - Romania - Bucharest
Posts: 146
Thanks: 10
Thanked 22 Times in 22 Posts
Default

As I understand you manage to install courier-authlib.... good. As for your new problem - I've checked the link from the mirror - it is down (Sorry for that!).

Here is a ne link for postfix ftp://ftp.chg.ru/pub/Linux/CentOS/5.....el5_2.src.rpm


Code:
wget ftp://ftp.chg.ru/pub/Linux/CentOS/5.4/os/SRPMS/postfix-2.3.3-2.1.el5_2.src.rpm
Reply With Quote
The Following User Says Thank You to Ghostdare For This Useful Post:
idsinc (15th April 2010)
  #6  
Old 15th April 2010, 15:44
idsinc idsinc is offline
Member
 
Join Date: Feb 2010
Posts: 56
Thanks: 14
Thanked 0 Times in 0 Posts
Talking perfect-server-centos-5.3-x86_64-ispconfig-3

Quote:
Originally Posted by Ghostdare View Post
As I understand you manage to install courier-authlib.... good. As for your new problem - I've checked the link from the mirror - it is down (Sorry for that!).

Here is a ne link for postfix ftp://ftp.chg.ru/pub/Linux/CentOS/5.....el5_2.src.rpm


Code:
wget ftp://ftp.chg.ru/pub/Linux/CentOS/5.4/os/SRPMS/postfix-2.3.3-2.1.el5_2.src.rpm

That worked perfectly... thank you much!
Reply With Quote
  #7  
Old 15th April 2010, 16:13
idsinc idsinc is offline
Member
 
Join Date: Feb 2010
Posts: 56
Thanks: 14
Thanked 0 Times in 0 Posts
Default perfect-server-centos-5.3-x86_64-ispconfig-3

New error, still page 4:

rpmbuild - ba postfix.spec

error: line 150: Bad arg to %patch -p: %package pflogsumm
Reply With Quote
  #8  
Old 15th April 2010, 17:59
Ghostdare Ghostdare is offline
Senior Member
 
Join Date: Aug 2009
Location: Europe - Romania - Bucharest
Posts: 146
Thanks: 10
Thanked 22 Times in 22 Posts
Default

Please check again the "postfix.spec". Go to line 150 and tell me exactly what is written there. (maybe you modified by mistake that line)

Q: When you work on the server are you using puTTY? Because if you enter by hand all this im sure that you have some typo problem (via SSH you can copy/paste very easy - i recommand that).

I see that you reply on this thread very slowly - i think that we are on different time zone.
Reply With Quote
  #9  
Old 15th April 2010, 18:36
idsinc idsinc is offline
Member
 
Join Date: Feb 2010
Posts: 56
Thanks: 14
Thanked 0 Times in 0 Posts
Default perfect-server-centos-5.3-x86_64-ispconfig-3

Quote:
Originally Posted by Ghostdare View Post
Please check again the "postfix.spec". Go to line 150 and tell me exactly what is written there. (maybe you modified by mistake that line)

Q: When you work on the server are you using puTTY? Because if you enter by hand all this im sure that you have some typo problem (via SSH you can copy/paste very easy - i recommand that).

I see that you reply on this thread very slowly - i think that we are on different time zone.
line 150:

%package pflogsumm

I added only:

MYSQL 1

Patch0 postfix-2.3.3-vda.patch

%patch0 -pl -b .vda

I'm pretty new at this, and I don't know what puTTY is..

so far, my biggest typo was vi sudo... I made a freudain assumption..lol.

PS.. I'm in Minnesota

Last edited by idsinc; 15th April 2010 at 18:45.
Reply With Quote
  #10  
Old 15th April 2010, 19:38
Ghostdare Ghostdare is offline
Senior Member
 
Join Date: Aug 2009
Location: Europe - Romania - Bucharest
Posts: 146
Thanks: 10
Thanked 22 Times in 22 Posts
 
Default

PuTTY is a SSH client - contect to the server to work as in terminal or command line.

Recomandation: before you do something like that try to work with the tutorial in a virtual machie - to see if it works or not.

In my opinion try to make your server in a Debian ... it's recomended and tested by the ISPConfig creators.

I think that you can ignore that error, you don't need that file. Just "cd /usr/src/redhat/RPMS/x86_64" (assuming that you have a 64 machine)
then "ls -l" and if you have there "postfix-2.3.3-2.1.x86_64.rpm" I think that you can muv on to the next (Pick the Postfix package and install it like this: rpm -ivh postfix-2.3.3-2.1.x86_64.rpm)

Last edited by Ghostdare; 15th April 2010 at 20:00.
Reply With Quote
The Following User Says Thank You to Ghostdare For This Useful Post:
idsinc (18th April 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 - CentOS 5.4 - SSL Problems!?! owainbaber Installation/Configuration 4 26th July 2011 17:12
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
Howtoforge the perfect Server(links) rini90 Installation/Configuration 0 14th December 2008 10:58
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44


All times are GMT +2. The time now is 04:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.