Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th April 2010, 22:42
yoplait yoplait is offline
Senior Member
 
Join Date: Dec 2009
Posts: 144
Thanks: 48
Thanked 14 Times in 11 Posts
Default Changing php_value for one vhost in fcgi...

Hi there,
I'm searching a way to use fcgi and to change the value of post_max-size and upload_file_maxsize for one site of my ispconfig configuration...

I understood that the global file is the /etc/php5/cgi/php.ini and it takes effect for all the sites with this. But how can i proceed for just one website ?

- I tried with an .htaccess at the website web folder,
- I tried with a directive in the vhost apache file,
- I tried with the options field, in ispconfig interface,

The phpinfo() file, on this website never changes...

ispconfig 3.0.2
OVH installation, Debian Lenny.

Thanks a lot !
Reply With Quote
Sponsored Links
  #2  
Old 17th April 2010, 21:42
yoplait yoplait is offline
Senior Member
 
Join Date: Dec 2009
Posts: 144
Thanks: 48
Thanked 14 Times in 11 Posts
Default

I can't imagine there is no solution about this problem...How do you do when you want to change a php value for a website usually with ispconfig3 ?
Reply With Quote
  #3  
Old 18th April 2010, 08:30
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default

Quote:
Originally Posted by yoplait View Post
.. to change the value of post_max-size and upload_file_maxsize for one site of my ispconfig configuration...
I've just tested this on my server (Centos5.4, but should work for any variation!)

1/ Go to the "sites" tab in the admin control panel
2/ Select the website from the list
3/ Select the website's "options" tab
4/ Within the apache directives add
Code:
php_admin_value post_max_size 16M
php_admin_value upload_max_filesize 10M
(or whatever value you want!)
5/ Click save
6/ WAIT for ISPconfig to process the job queue
7/ Test using PHPinfo()

et Voila!

--- edited to say
please note: make sure you get the setting names correct. Your post had them mistyped!

Last edited by mike_p; 18th April 2010 at 08:36.
Reply With Quote
  #4  
Old 18th April 2010, 10:42
yoplait yoplait is offline
Senior Member
 
Join Date: Dec 2009
Posts: 144
Thanks: 48
Thanked 14 Times in 11 Posts
Default

I tested exactly what you said, it does nothing at all... (The setting names was correct before too ).
I tried a php.ini (with apache2 restart), nothing changes...

The only setting that can change something is in the /etc/php5/cgi/php.ini, but it will affect all websites ...

I wonder of your configuration. What's your php option ? fcgi ? cgi ? suexec... etc ? (I'm confused with theses settings...)
Maybe a "strict" setting that I didn't think about ?
Reply With Quote
  #5  
Old 18th April 2010, 20:18
yoplait yoplait is offline
Senior Member
 
Join Date: Dec 2009
Posts: 144
Thanks: 48
Thanked 14 Times in 11 Posts
Default

Of course, do it in a global way should be ok, but the question is primary about my curiosity !

I've got really just one big site whereas others are very little ones... Moreover, the "client" want sometimes some php_value to be changed...

Anyway, I'm really frustated because I can't understand why it doesn't work ...
Reply With Quote
  #6  
Old 18th April 2010, 23:04
yoplait yoplait is offline
Senior Member
 
Join Date: Dec 2009
Posts: 144
Thanks: 48
Thanked 14 Times in 11 Posts
Default

I understand your point of view, and I think you're right, but I never tried to use VM and I don't have enough money to pay a new server and test it like this ^^ .

For my problem : the php.ini, in the website web folder, doesn't change anything...
I tried
Code:
post_max_size 49M
upload_max_filesize 49M
and
Code:
php_value post_max_size 49M
php_value upload_max_filesize 49M
I changed the owner of the php.ini from root to the web##:client## user,
I reloaded apache...
nothing ...
When you say "local php.ini is the only way"... You speak about the global php.ini file ?
Reply With Quote
  #7  
Old 19th April 2010, 10:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Take a look at chapters 5 and 6 on http://www.howtoforge.com/how-to-set...ebian-lenny-p2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
yoplait (22nd April 2010)
  #8  
Old 19th April 2010, 11:14
yoplait yoplait is offline
Senior Member
 
Join Date: Dec 2009
Posts: 144
Thanks: 48
Thanked 14 Times in 11 Posts
Default

I didn't know the php-fcgi-starter file, but it doesn't work either...
Is there a variable, somewhere, that tells apache2 to do not take in consideration the local settings ?

I tried in CGI only, in fast-cgi, (and without suexec, ssi...)...it's the same ...
Reply With Quote
  #9  
Old 20th April 2010, 14:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Can you post your current vhost configuration?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 20th April 2010, 17:51
yoplait yoplait is offline
Senior Member
 
Join Date: Dec 2009
Posts: 144
Thanks: 48
Thanked 14 Times in 11 Posts
 
Default

Here is my vhost where "domaine" is my domain .
Code:
<Directory /var/www/domaine.org>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/clients/client0/web4/web
  
    ServerName domaine.org
    ServerAlias www.domaine.org
    ServerAdmin webmaster@domaine.org

    ErrorLog /var/log/ispconfig/httpd/domaine.org/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html
	
    <Directory /var/www/domaine.org/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/client0/web4/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    # php as cgi enabled
    ScriptAlias /php5-cgi /var/www/php-cgi-scripts/web4/php-cgi-starter
    Action php5-cgi /php5-cgi
    AddHandler php5-cgi .php .php3 .php4 .php5
    <Directory /var/www/php-cgi-scripts/web4/>
        Order allow,deny
        Allow from all
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId web4 client0
    </IfModule>


</VirtualHost>
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
chgrp error new user DKA General 15 28th July 2008 17:45


All times are GMT +2. The time now is 03:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.