Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th May 2006, 06:43
Joffar Joffar is offline
Member
 
Join Date: Feb 2006
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with SPF configuration

I have added a SPF entry in the DNS manager, but for some reason when running the http://www.dnsreport.com/ it keeps giving me a warning that my domain doesn't have a SPF record.
When checking my pri.domain.org it indicates that I have a SPF record.

I have two email accounts to the same domain, so I would think that if I have a SPF record for the domain that would be sufficient..

Any idea as to what I do wrong?

Any help is appreciated.

Output from /etc/bind/pri.domain.org
(Tried to add the mail.domain.org but it seems that it didnt help any.)
Code:
$TTL        86400
@       IN      SOA     domain.org. admin.domain.org. (
                        2006052805       ; serial, todays date + todays serial #
                        28800              ; refresh, seconds
                        7200              ; retry, seconds
                        604800              ; expire, seconds
                        86400 )            ; minimum, seconds
;
                NS      domain.org.              ; Inet Address of name server 1
                NS      domain.org.              ; Inet Address of name server 2
;

  MX      10 domain.org.
www  MX      10 domain.org.

domain.org.      A        1.2.3.4
www       A       1.2.3.4
gallery       A       1.2.3.4
blog       A       1.2.3.4

domain.org.       TXT  "v=spf1 a mx ~all"
www.domain.org.       TXT  "v=spf1 a mx ~all"

;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;
mail.domain.org.      IN TXT  "v=spf1 a ~all"
Reply With Quote
Sponsored Links
  #2  
Old 30th May 2006, 16:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Is your ISPConfig server the authoritative name server for the domain? Do you see it in the output of
Code:
dig ns domain.com
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st May 2006, 02:48
Joffar Joffar is offline
Member
 
Join Date: Feb 2006
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I guess not since I am using no-ip to redirect to my server...Heres the output...

Code:
; <<>> DiG 9.3.2 <<>> ns blumonkey.org
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30852
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 5

;; QUESTION SECTION:
;blumonkey.org.                 IN      NS

;; ANSWER SECTION:
blumonkey.org.          86400   IN      NS      ns3.no-ip.com.
blumonkey.org.          86400   IN      NS      ns4.no-ip.com.
blumonkey.org.          86400   IN      NS      ns5.no-ip.com.
blumonkey.org.          86400   IN      NS      ns1.no-ip.com.
blumonkey.org.          86400   IN      NS      ns2.no-ip.com.

;; ADDITIONAL SECTION:
ns4.no-ip.com.          82004   IN      A       198.65.102.15
ns5.no-ip.com.          82004   IN      A       212.100.249.200
ns1.no-ip.com.          82004   IN      A       216.66.37.13
ns2.no-ip.com.          82004   IN      A       204.16.252.6
ns3.no-ip.com.          82004   IN      A       63.208.74.226

;; Query time: 186 msec
;; SERVER: 192.168.0.1#53(192.168.0.1)
;; WHEN: Tue May 30 19:41:21 2006
;; MSG SIZE  rcvd: 210
Reply With Quote
  #4  
Old 31st May 2006, 15:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
 
Default

This means your server is not authoritative for your domain. You must create the SPF record on those no-ip name servers.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with groups/grpconv linuxfast General 28 21st April 2008 10:35
Empty Recycle Bin jon335 General 40 6th May 2006 12:56
Tor Configuration Problems sbovisjb1 Installation/Configuration 2 30th April 2006 02:59
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 20:29
ISPConfig pop3 problem mphayesuk General 21 31st October 2005 11:53


All times are GMT +2. The time now is 01:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.