Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th March 2010, 07:13
deckerz deckerz is offline
Junior Member
 
Join Date: Mar 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix - Can send email but not receiving any email

Hello,

I setup SMTP Gateway using Sophos Puremessage. My MTA is postfix. I have problem receiving email but I can send email. From mail header I can see that my mail server send directly to the internet. Incoming email will go through the Puremessage server.

My mail flow as below:
Internet ----> Puremessage server ----> internal mail server
internal mail server -----> Internet

from maillog, I see this :
NOQUEUE: reject: RCPT from outmail004.ash1.tfbnw.net[69.63.184.104]: 554 5.7.1 <maran@parlimen.gov.my>: Relay access denied;

If I try to send email from yahoo account, I got this error:
Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<maran@parlimen.gov.my>:
202.185.178.6 does not like recipient.
Remote host said: 554 5.7.1 <maran@parlimen.gov.my>: Relay access denied
Giving up on 202.185.178.6.

Can anyone help me on this?

####################

After I add $mydomain in destination address, I got this error when sending email from yahoo account:


Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<maran@parlimen.gov.my>:
202.185.178.6 does not like recipient.
Remote host said: 550 5.1.1 <maran@parlimen.gov.my>: Recipient address rejected: User unknown in local recipient table
Giving up on 202.185.178.6.

Last edited by deckerz; 20th March 2010 at 07:37. Reason: add error
Reply With Quote
Sponsored Links
  #2  
Old 21st March 2010, 23:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you set up an email account for maran@parlimen.gov.my? If so, how exactly? What's in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd March 2010, 10:01
deckerz deckerz is offline
Junior Member
 
Join Date: Mar 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, maran is valid. All mail account in internal mail server which is cpanel. Current problem is in Sophos Puremessage server.

Internet---->Puremessage---->Internal Mail server

Below is main.cf config:

queue_directory = /opt/pmx/postfix/var/spool/mqueue
command_directory = /opt/pmx/postfix/sbin
daemon_directory = /opt/pmx/postfix/libexec
data_directory = /opt/pmx/postfix/var/lib/postfix
mail_owner = postfix
unknown_local_recipient_reject_code = 550
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
ddd $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /opt/pmx/postfix/sbin/sendmail
newaliases_path = /opt/pmx/postfix/bin/newaliases
mailq_path = /opt/pmx/postfix/bin/mailq
setgid_group = postdrop
html_directory = /opt/pmx/postfix/doc/html
manpage_directory = /opt/pmx/postfix/man
sample_directory = /opt/pmx/postfix/doc/samples
readme_directory = /opt/pmx/postfix/doc
smtp_generic_maps = pcre:/opt/pmx/postfix/etc/smtp_generic_maps
alias_database = hash:/opt/pmx/postfix/etc/aliases
alias_maps = hash:/opt/pmx/postfix/etc/aliases
transport_maps = hash:/opt/pmx/postfix/etc/transport
recipient_delimiter = +
myhostname = pmx.parlimen.gov.my
mynetworks =
relayhost =
content_filter = pmx:127.0.0.1:10025
mydomain = parlimen.gov.my
mydestination = $myhostname, localhost.$mydomain, localhost
myorigin = $myhostname
smtpd_client_restrictions = ignore_policy_error,check_policy_service inet:localhost:4466

Last edited by deckerz; 22nd March 2010 at 10:11.
Reply With Quote
  #4  
Old 23rd March 2010, 01:08
drillsar drillsar is offline
Junior Member
 
Join Date: Jul 2009
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm having same problem I think it's because my ISP blocks port 25 and probably yours as well.
Reply With Quote
  #5  
Old 23rd March 2010, 03:53
deckerz deckerz is offline
Junior Member
 
Join Date: Mar 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

When I bypass the Puremessage server, I can receive incoming email directly to internal server. But if I bypass the Puremessage server, no use we bought the Puremessage SMTP Gateway, right? I'm sure its not ISP problem because internal mail server can send and receive email correctly after I tried remove the Puremessage server.
Reply With Quote
  #6  
Old 23rd March 2010, 12:44
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,149
Thanks: 4
Thanked 56 Times in 52 Posts
Default

just curious, is that the IP of your mailserver:

202.185.178.6 ?


And also can you paste your alias map and did you run postmap on the alias file?
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator

Last edited by sjau; 23rd March 2010 at 12:48.
Reply With Quote
  #7  
Old 8th April 2010, 18:32
trondhuso trondhuso is offline
Junior Member
 
Join Date: Mar 2010
Location: Mysen, Norway
Posts: 24
Thanks: 1
Thanked 3 Times in 2 Posts
 
Default I possible solution

I had the same problem. My log (/var/log/mail.log) also had items like:
warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable

By running: postmap /etc/postfix/virtusertable

The problem was solved.

Hope it helps someone as I have spent a few hours finding the solution.

Trond
Reply With Quote
The Following User Says Thank You to trondhuso For This Useful Post:
falko (9th April 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending emails with custom FROM email address merisor Installation/Configuration 4 8th February 2010 17:27
Postfix email server config veremchook Server Operation 10 18th April 2009 17:14
Postfix won't receive external email fred!head Server Operation 2 29th June 2008 20:30
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 10:40
Postfix will not send email godsfshrmn HOWTO-Related Questions 1 15th December 2007 17:14


All times are GMT +2. The time now is 15:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.