#1  
Old 2nd April 2010, 11:00
createch createch is offline
Senior Member
 
Join Date: Aug 2007
Posts: 118
Thanks: 24
Thanked 16 Times in 13 Posts
Default Problem in DNS

Hi I really need some advice.....

Years ago, I have set up a ISPconfig server (Fedora 5, ISPConfig later upgraded to 2.2.35) and the DNS services works without problem.

The IP of the server is 210.17.XXX.66.

For example, I have the following domains hosted in my server using ISPConfig:
www.111.com
www.222.com
www.333.com

and then if I set my client's PC to use 210.17.XXX.66 as DNS server, it can resolve all the above domains, and for those "external domains" (e.g. www.google.com), it can resolve too.

However, recently I set up a new server with ISPConfig (Fedora 12, ISPConfig 2.2.35), the DNS services is little strange...

Now, the IP of the server is 210.17.XXX.67.

Same as the old server, if the ISPConfig has the following domains:
www.111.com
www.222.com
www.333.com

and then if I set up my client's PC to use 210.17.XXX.67 as DNS server, it can resolve all the above "internal" domains, but it cannot resolve any extenal domains now (e.g. www.google.com, www.apple.com ... all cannot be resolved)

Any possible way to make the new Fedora 12 ISPconfig server able to resolve to those "external" domains too ? Thanks in advance.

Createch
Reply With Quote
Sponsored Links
  #2  
Old 2nd April 2010, 14:18
createch createch is offline
Senior Member
 
Join Date: Aug 2007
Posts: 118
Thanks: 24
Thanked 16 Times in 13 Posts
 
Default

Hi , I solved it by myself.... by using allow-recursion directive.

(Actually I do not think allow-recursion is good -- anyway it fixed the problem which is requested to be fixed by my client.)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with some scopes of DNS A records - Adress invalid radim_h Installation/Configuration 1 21st February 2010 13:35
DNS problem mrmagoo Installation/Configuration 1 1st September 2007 08:59
No SPF record. beryl Installation/Configuration 6 17th May 2007 20:52
DNS Problem with mailserver pesja Installation/Configuration 5 14th July 2006 15:42
DNS issue and user's alias problem rosa hsiao General 3 2nd November 2005 11:03


All times are GMT +2. The time now is 20:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.