Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th March 2010, 00:19
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 478
Thanks: 78
Thanked 39 Times in 33 Posts
Default New site default files

I'm writing a custom index.html page for new sites. It's ultimate intention is to run a php script for a semi installation of the joomla package. I've modified the index.html page without problem but i need a couple of php pages also to be copied to new sites.

I read a thread in which applied to ispconfig2 here
http://www.howtoforge.com/forums/showthread.php?t=213
but I couldn't seem to find the files in ispconfig3.

How can I achieve the same in ispconfig3?
Reply With Quote
Sponsored Links
  #2  
Old 30th March 2010, 20:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

You can write a new server plugin and attach it to the website create events. There are several threads about this in the developer forum and take a look at the apache plugin to get some example code.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st April 2010, 20:48
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 478
Thanks: 78
Thanked 39 Times in 33 Posts
 
Default

Quote:
Originally Posted by till View Post
You can write a new server plugin and attach it to the website create events. There are several threads about this in the developer forum and take a look at the apache plugin to get some example code.
Thanks, I've been searching around the forum and am struggling to find this. I'm searching using the words 'apache plugin'

Can I edit the default script that tells it to copy the standard index, favicon etc? If i can where would i find this?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
RoundCube Sends but will not receive. happz Installation/Configuration 33 17th April 2010 21:55
Can all the installation and configuration be automated (Kickstart) gabby Installation/Configuration 0 30th January 2010 19:47
apache2 won't connect to localhost or 127.0.0.1 anw Server Operation 6 19th March 2009 18:51
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 17:57
Network questions regarding Ubuntu Server lubod Installation/Configuration 7 3rd January 2007 18:53


All times are GMT +2. The time now is 22:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.