#1  
Old 21st May 2006, 15:30
ZC1 ZC1 is offline
Junior Member
 
Join Date: May 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Apache 2.0.52 - mod_dir.c

Hi,

In the past I used Apache 1.3.x which had the below lines in the httpd.conf and also in AddModule mod_dir.c

<IfModule mod_dir.c>
DirectoryIndex index.html index.wml index.cgi index.shtml index.jsp index.js index.jp index.php4 index.php3 index.php index.phtml index.htm
default.htm default.html home.htm
</IfModule>


Now I am using Apache 2.0.52 with was installed, when I installed CentOS 4.3.
In the httpd.conf there is: LoadModule mod_dir.so but that the only part that has anything to do with mod_dir in the httpd.conf

When I run the command: 'httpd -l' I get:

Compiled in modules:
core.c
prefork.c
http_core.c
mod_so.c

How do I install mod_dir.c into Apache 2.0.52 ?

Or do I have to upgrade to Apache 2.0.58 or will I need to install Apache 2.2.2, or would I be better to go down to 1.3.36 ?

I am also having another problem which I believe is related to the missing mod_dir.c which is all addresses in the browse must have the

trailing / or the address fails.

Regards,
Garry
Reply With Quote
Sponsored Links
  #2  
Old 21st May 2006, 20:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
 
Default

Quote:
Originally Posted by ZC1
I am also having another problem which I believe is related to the missing mod_dir.c which is all addresses in the browse must have the

trailing / or the address fails.

Regards,
Garry
This happens because the ServerName in your Apache configuration is different from the URL you use.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mod_mono apache 2.2 ColdDoT Server Operation 5 23rd May 2006 02:58
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45
PHP/MySQL/Apache2/ISPConfig configuration issues? senzapaura General 21 25th December 2005 14:01
install apache 1.3 on FC 4 superg Server Operation 1 22nd December 2005 17:44
Apache 1.3 Support SleeperZ General 3 9th November 2005 11:10


All times are GMT +2. The time now is 04:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.