Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th February 2006, 23:54
ccix ccix is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix Problem / Question

I keep seeing this error in auth.log I've read the other threads about this issue and didn't see a way to solve it. I've double checked all my config files from the debian 3.1 how to.

Here's what it shows over and over again every few minutes. Any ideas? Thanks

Eric


Feb 25 14:21:10 ns postfix/smtpd[7773]: sql_select option missing
Feb 25 14:21:10 ns postfix/smtpd[7773]: auxpropfunc error no mechanism available
Feb 25 14:21:10 ns postfix/smtpd[7773]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:24:10 ns postfix/smtpd[7789]: sql_select option missing
Feb 25 14:24:10 ns postfix/smtpd[7789]: auxpropfunc error no mechanism available
Feb 25 14:24:10 ns postfix/smtpd[7789]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:30:35 ns postfix/smtpd[7793]: sql_select option missing
Feb 25 14:30:35 ns postfix/smtpd[7793]: auxpropfunc error no mechanism available
Feb 25 14:30:35 ns postfix/smtpd[7793]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:30:53 ns postfix/smtpd[7808]: sql_select option missing
Feb 25 14:30:53 ns postfix/smtpd[7808]: auxpropfunc error no mechanism available
Feb 25 14:30:53 ns postfix/smtpd[7808]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:33:44 ns postfix/smtpd[7814]: sql_select option missing
Feb 25 14:33:44 ns postfix/smtpd[7814]: auxpropfunc error no mechanism available
Feb 25 14:33:44 ns postfix/smtpd[7814]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:35:45 ns postfix/smtpd[7820]: sql_select option missing
Feb 25 14:35:45 ns postfix/smtpd[7820]: auxpropfunc error no mechanism available
Feb 25 14:35:45 ns postfix/smtpd[7820]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:35:49 ns postfix/smtpd[7831]: sql_select option missing
Feb 25 14:35:49 ns postfix/smtpd[7831]: auxpropfunc error no mechanism available
Feb 25 14:35:49 ns postfix/smtpd[7831]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Reply With Quote
Sponsored Links
  #2  
Old 26th February 2006, 17:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Which tutorial are you referring to (URL)?

Did you have a look at this thread? http://www.howtoforge.com/forums/showthread.php?t=861
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 26th February 2006, 23:36
ccix ccix is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I took a look at everything in that thread and made a few changes. One was linking the directory for the .pid file which made restarting sasl work fine. I also checked the other file listed at the end of the thread, tried it both ways listed and still received this.


Feb 26 14:33:53 ns saslauthd[17727]: server_exit : master exited: 17727
Feb 26 14:33:54 ns saslauthd[17933]: detach_tty : master pid is: 17933
Feb 26 14:33:54 ns saslauthd[17933]: ipc_init : listening on socket: /var/spool/postfix/var/run/saslauthd/mux
Feb 26 14:34:08 ns postfix/smtpd[17939]: sql_select option missing
Feb 26 14:34:08 ns postfix/smtpd[17939]: auxpropfunc error no mechanism available
Feb 26 14:34:08 ns postfix/smtpd[17939]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql


Sasl starts fine but still gets that error in the log file. Any other ideas?
Reply With Quote
  #4  
Old 27th February 2006, 01:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's in your /etc/pam.d/smtp?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 27th February 2006, 07:50
ccix ccix is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ns:~# cat /etc/pam.d/smtp
auth required pam_mysql.so user=mail_admin passwd=abcd1234 host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1
account sufficient pam_mysql.so user=mail_admin passwd=abcd1234 host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1


I'm going to recheck step by step on the how to's ...do i need to do the Debian sarge (all 5 pages?) and then use all the mysql-postfix-etc setup also? Sorry i didn't use exact names, only have a second to reply before i nee to leave. Let me know about the above.

Eric
Reply With Quote
  #6  
Old 27th February 2006, 10:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by ccix
do i need to do the Debian sarge (all 5 pages?) and then use all the mysql-postfix-etc setup also?
No, just the basic Debian installation (the first two pages of the "Perfect Setup" for Debian Sarge).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 27th February 2006, 12:23
ccix ccix is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Another note, i'm NOT using ISPConfig. I'll compare my settings again but when i looked earlier i couldn't find anything offset.

Thanks

If you have any other ideas...let me know.
Reply With Quote
  #8  
Old 1st April 2010, 19:03
Peter Murfy Peter Murfy is offline
Junior Member
 
Join Date: Oct 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Removing libsql from the /usr/lib/sasl2 directory solved my problem.

Peter

Found it here:
http://marc.info/?l=postfix-users&m=118062660123427
Reply With Quote
  #9  
Old 3rd April 2010, 12:39
King Sami King Sami is offline
Junior Member
 
Join Date: Apr 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I'm sorry to post this in sendmail forum topic because i did't see such as postfix forum.

I'm a newbie with linux
I using Redhat 9.0 and postfix program.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix ISPconfig problem matehortua Installation/Configuration 8 3rd September 2006 18:03
postfix problem lerra Installation/Configuration 11 6th February 2006 17:23
Suse Postfix + Dovecot + ISP Config + smtp Auth; recieving problem! fatum112 HOWTO-Related Questions 2 15th January 2006 20:03
postfix problem flourishing General 1 7th December 2005 18:39
Postfix Problem m u r Installation/Configuration 0 8th August 2005 20:12


All times are GMT +2. The time now is 12:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.