Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th March 2010, 21:06
wxman wxman is offline
Senior Member
 
Join Date: May 2007
Posts: 189
Thanks: 11
Thanked 2 Times in 2 Posts
Default Installing xen and LVM on Ubuntu 8.04 server

I'm running Ubuntu 8.04 server that I testing out using LVM based xen virtual servers. I opened up the backports in my sources.list, then installed using one of the HowTos "aptitude install ubuntu-xen-server". The install went as it should, then I made my firat test image using:
Code:
xen-create-image --hostname=test1.test.com --lvm=vg0 --size=10Gb --swap=1Gb --ip=192.168.31.231 --force --memory=50Mb --arch=amd64 --debootstrap
After it finishes I use xm create to start the virtual machine but I keep getting:
Code:
Error: (38, 'Function not implemented')
I even tried uninstalling, then reinstalling xen but that didn't help. Has anyone seen this before, or know how to take care of it?
Reply With Quote
Sponsored Links
  #2  
Old 29th March 2010, 15:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Can you post the configuration file of the VM?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th March 2010, 16:27
wxman wxman is offline
Senior Member
 
Join Date: May 2007
Posts: 189
Thanks: 11
Thanked 2 Times in 2 Posts
Default

Code:
# Configuration file for the Xen instance test1.tlthost.net, created
# by xen-tools 3.8 on Sun Mar 28 14:46:54 2010.
#

#
#  Kernel + memory size
#
kernel      = '/boot/vmlinuz-2.6.24-27-xen'
ramdisk     = '/boot/initrd.img-2.6.24-27-xen'
memory      = '50'

#
#  Disk device(s).
#
root        = '/dev/xvda2 ro'
disk        = [
                  'phy:/dev/vg0/test1.tlthost.net-swap,xvda1,w',
                  'phy:/dev/vg0/test1.tlthost.net-disk,xvda2,w',
              ]


#
#  Hostname
#
name        = 'test1.tlthost.net'

#
#  Networking
#
vif         = [ 'ip=192.168.31.231,mac=00:16:3E:52:A0:C9' ]

#
#  Behaviour
#
on_poweroff = 'destroy'
on_reboot   = 'restart'
on_crash    = 'restart'

extra = '2 console=xvc0'
Reply With Quote
  #4  
Old 30th March 2010, 14:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Looks ok. The only "solution" I could find on the net is to reinstall Xen: http://old.nabble.com/Error-on-xm-cr...d21546579.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 30th March 2010, 17:00
wxman wxman is offline
Senior Member
 
Join Date: May 2007
Posts: 189
Thanks: 11
Thanked 2 Times in 2 Posts
 
Default

I actually found that very same article. I already did a aptitude --purge remove, then did the whole install again. I'm going to try an ask the xen people if they know anything. I'm not too hopeful because there are no answers on the web already. I'll post here if I find a fix.
Thanks Falco
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Backing up Xen DomUs - NFS vs. LVM Snapshots atjensen11 Installation/Configuration 4 20th August 2009 18:18
Installing Xen 3.3 on Ubuntu 8.10-failure to create LVM image jlain HOWTO-Related Questions 2 6th April 2009 17:39
Ubuntu 8.04 LTS - RAID 1 + LVM + XEN atjensen11 HOWTO-Related Questions 1 20th January 2009 20:35
Centos5 - Xen - DomU with LVM jgijsen HOWTO-Related Questions 2 27th February 2008 11:57
Xen: Smp & Lvm zokahn HOWTO-Related Questions 5 27th January 2006 10:28


All times are GMT +2. The time now is 14:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.