Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th December 2013, 14:03
tfboy tfboy is offline
Junior Member
 
Join Date: Dec 2013
Posts: 20
Thanks: 3
Thanked 1 Time in 1 Post
Default roundcube shown on root url, not just webmail

I now have my server set up with ISPconfig OK, just one thing is bugging me.
I've followed the perfect server guides and am using roundcube instead of squirrelmail. It's working ok, both on https://webmail.example.com and also https://example.com/webmail however it's also responding on all the master domains too such as https://example.com and https://www.example.com which I'd like to remove because I might add a normal ssl website in the future.
I've been through my various apache conf files and can't figure out how to remove it.

Code:
# Those aliases do not work properly with several hosts on your apache server
# Uncomment them to use it or adapt them to your configuration
#    Alias /roundcube/program/js/tiny_mce/ /usr/share/tinymce/www/
#    Alias /roundcube /var/lib/roundcube
Alias  /webmail        /var/lib/roundcube

# Access to tinymce files
<Directory "/usr/share/tinymce/www/">
      Options Indexes MultiViews FollowSymLinks
      AllowOverride None
      Order allow,deny
      allow from all
</Directory>

<Directory /var/lib/roundcube/>
  Options +FollowSymLinks
  DirectoryIndex index.php
  <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .:/usr/share/php
  </IfModule>
  # This is needed to parse /var/lib/roundcube/.htaccess. See its
  # content before setting AllowOverride to None.
  AllowOverride All
  order allow,deny
  allow from all
</Directory>

# Protecting basic directories:
<Directory /var/lib/roundcube/config>
        Options -FollowSymLinks
        AllowOverride None
</Directory>

<Directory /var/lib/roundcube/temp>
        Options -FollowSymLinks
        AllowOverride None
        Order allow,deny
        Deny from all
</Directory>

<Directory /var/lib/roundcube/logs>
        Options -FollowSymLinks
        AllowOverride None
        Order allow,deny
        Deny from all
</Directory>

<VirtualHost *:443>
  DocumentRoot /var/lib/roundcube
  ServerName webmail.example.com
  SSLEngine On
  SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
  SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
</VirtualHost>
Any ideas?

edit: I suppose this could be because this is the roundcube file in /etc/apache2/conf.d/ (which is a link to /etc/roundcube/apache2.conf) instead of a vhost file. I'm still learning and getting confused between the files in conf.d and normal vhost files in /etc/apache2/sites-available. Maybe the problem would go away if I were to somehow migrate this into a dedicated vhost file ensuring it only responds to the aliases and paths definded?

Last edited by tfboy; 27th December 2013 at 14:07.
Reply With Quote
Sponsored Links
  #2  
Old 27th December 2013, 14:41
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 262 Times in 208 Posts
Default

If there is only one vhost configured for port 443 then this one is always shown.

You can change this if you enter a "ServerName" (and maybe ServerAlias) for the domain you want to use for webmailing in the roundcube vhost/conf file.
Then create a second SSL site that is the default vhost for port 443. This one is shown on all other domain names then.
__________________
Marius Cramer

pixcept KG
Reply With Quote
The Following User Says Thank You to Croydon For This Useful Post:
tfboy (27th December 2013)
  #3  
Old 27th December 2013, 14:49
tfboy tfboy is offline
Junior Member
 
Join Date: Dec 2013
Posts: 20
Thanks: 3
Thanked 1 Time in 1 Post
Default

Super danke Marius
Reply With Quote
  #4  
Old 27th December 2013, 14:53
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 262 Times in 208 Posts
Default

No problem
Just a side-note:
You can see what vhost is the current default (fallback) one by typing
Code:
apache2ctl -t -D DUMP_VHOSTS
__________________
Marius Cramer

pixcept KG
Reply With Quote
  #5  
Old 27th December 2013, 14:56
tfboy tfboy is offline
Junior Member
 
Join Date: Dec 2013
Posts: 20
Thanks: 3
Thanked 1 Time in 1 Post
 
Default

Ahh, very useful indeed. I'll make a note of that for future reference.
Thanks again.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
saslauthd Error while Sending Mail Naja Server Operation 6 1st April 2009 20:41
messed up apache2-php5 installation klonos HOWTO-Related Questions 2 24th January 2009 23:12
Missing Email dayjahone General 7 30th June 2008 15:29
i am having some problem ? cobro Installation/Configuration 20 30th April 2008 16:26
Apache - Virtual hosts - ISPConfig Hans Server Operation 8 23rd April 2006 16:29


All times are GMT +2. The time now is 07:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.