#1  
Old 11th March 2010, 15:17
rchood rchood is offline
Junior Member
 
Join Date: Oct 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default ASP website

Hello,

I have a question about .asp websites.
I want to host a .asp website but it doens't work. The code is displayed in plain text.
I use Debian Lenny with the ISPconfig3.
The machine is installed with the help of this howto:
http://www.howtoforge.com/perfect-se...nny-ispconfig3

What do i need to do before i can host .asp websites?

Greetz Rchood
Reply With Quote
Sponsored Links
  #2  
Old 11th March 2010, 15:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

.asp pages are pages for windows webservers and not Linux Servers. There is a tool called apache asp to run them (at least partially) on linux, but I dont have any experience how complete this solution is. See

http://www.apache-asp.org/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th March 2010, 04:25
Doug G Doug G is offline
HowtoForge Supporter
 
Join Date: Apr 2008
Posts: 71
Thanks: 0
Thanked 8 Times in 6 Posts
Default

apache::asp doesn't provide vbscript, which makes it useless for about 98% of the asp code in existence. Sun used to have an asp emulator for linux that worked pretty well, I know that Snitz forums (an asp-based forum) ran on the sun one emulation.

Your best bet if you need to offer asp is to use a windows server.
__________________
=====
Doug G
=====
Reply With Quote
  #4  
Old 19th March 2010, 15:18
rchood rchood is offline
Junior Member
 
Join Date: Oct 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks for the comments.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig won't host website but not mail zetnsh Installation/Configuration 4 11th March 2008 07:44
cannot receive emails after made website online llamy General 20 27th December 2007 02:14
set up 301 redirect from old website to new website showe1966 Server Operation 1 22nd September 2007 13:30
How to config Chili!soft ASP connect database mdb mulinux Installation/Configuration 0 15th November 2006 04:54


All times are GMT +2. The time now is 18:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.