Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 22nd March 2010, 12:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,236 Times in 4,104 Posts
Default

Maybe you entered a wrong mysql server as you installed ispconfig? The mysql server must be "localhost" as the installer suggest you and not "127.0.0.1" as this causes plroblems with mysql logins, the mysql daemon is not able to determine that 127.0.0.1 and localhost are the same.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #22  
Old 22nd March 2010, 13:22
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

I've given ispconfig access via 127.0.0.1 and localhost and it was working fine before for months after the initial setup but I still have a problem with ispconfig thinking MySQL isn't running.
Reply With Quote
  #23  
Old 22nd March 2010, 18:43
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

Is fetchmail affected by SASL settings? I've just noticed my SASL setup needs tweaking, I'm getting error messages.
Reply With Quote
  #24  
Old 23rd March 2010, 17:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,724 Times in 2,564 Posts
Default

Can you post the error messages?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #25  
Old 23rd March 2010, 17:44
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

It prints these in the log every so often:

postfix/smtpd[4784]: warning: SASL: Connect to private/auth failed: No such file or directory
postfix/smtpd[4784]: fatal: no SASL authentication mechanisms
postfix/master[2495]: warning: process /usr/libexec/postfix/smtpd pid 4784 exit status 1
postfix/master[2495]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Reply With Quote
  #26  
Old 24th March 2010, 14:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,724 Times in 2,564 Posts
Default

I found a comment on this page that might help: http://johnny.chadda.se/2007/04/15/m...rey-and-dspam/

What's the output of
Code:
ls -la /var/spool/postfix/private/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #27  
Old 24th March 2010, 15:58
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

Which comment is it?

Code:
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 amavis
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 anvil
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 bounce
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 bsmtp
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 cyrus
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 defer
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 discard
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 dovecot
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 error
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 ifmail
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 lmtp
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 local
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 maildrop
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 old-cyrus
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 proxymap
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 relay
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 rewrite
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 scache
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 smtp
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 tlsmgr
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 trace
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 uucp
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 verify
srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 virtual
Reply With Quote
  #28  
Old 25th March 2010, 13:13
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

I've managed to clear up most of the error messages by going through the various conf files and changing 127.0.0.1 to localhost wherever a MySQL connection is used which is a bit of a kludge as if I ever update any of the software I'll have to do that again but I still have problems with software trying to connect to MySQL on 127.0.0.1 and it failing.

I turned off iptables to see if it was a rule stopping this from working but that didn't sort it.

I ran:

Code:
GRANT ALL PRIVILEGES ON *.*
  TO 'root'@'%'
  IDENTIFIED BY '<my_password>'
  WITH GRANT OPTION;
to see if resetting the privileges would help but it didn't

Whenever anything tries to connect to MySQL on 127.0.0.1 I get:

Code:
ERROR 2003 (HY000): Can't connect to MySQL server on '127.0.0.1' (111)
It's really frustrating as I know even if I find every reference on my entire system to 127.0.0.1 and change it to localhost all I have to do is update a package that rewrites a conf somewhere and I'm back to this state.
Reply With Quote
  #29  
Old 25th March 2010, 17:14
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

I've just checked some of the settings on another machine on which I can access mysql via 127.0.0.1
When I run netstat -p I get:

Code:
tcp        0      0 *:mysql                     *:*                         LISTEN      22654/mysqld
But on my machine I get:

Code:
tcp        0      0 <my_domain>:mysql      *:*                         LISTEN      5353/mysqld
Does anyone know where I go to change the above setting?
I was wondering if it's listening on my domain instead of for all connections?
Reply With Quote
  #30  
Old 25th March 2010, 18:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,724 Times in 2,564 Posts
 
Default

On Debian/Ubuntu, you can change it in /etc/mysql/my.cnf. On other distributions it's most likely /etc/my.cnf.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting FTP bswinnerton Installation/Configuration 4 10th October 2008 19:34
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 21:12
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 19:38
Mail server attack princebenin Server Operation 1 19th November 2007 14:02
Website users? ctroyp General 25 6th January 2006 18:02


All times are GMT +2. The time now is 01:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.