Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > MyDNSConfig > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 17th March 2010, 12:01
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default file5

just to be clear, so i understand you and the DNS =)
Attached Images
 
Reply With Quote
Sponsored Links
  #12  
Old 17th March 2010, 12:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,444
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

Looks good now.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
trexen (17th March 2010)
  #13  
Old 17th March 2010, 18:41
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Smile not workin

Hi again!

Now that i know that MyDNSConfig is correctly configured, i try to connect to the web server pointing to my ispconfig 2.2.35 server holding mydomain.com but no answer, i try dig and nslookup

------------------------------------------------
trexen@mDNS:~$ dig ns domain.com

; <<>> DiG 9.5.1-P3 <<>> ns domain.com
;; global options: printcmd
;; connection timed out; no servers could be reached

trexen@mDNS:~$ nslookup domain.com
;; connection timed out; no servers could be reached
---------------------------------------------------

i talked to the company that have my domain.com and everything looks fine, they just forward my domain to my server (DNS)

i have no idea whats wrong.
port 53, 8080 are open and a ssh port, im able to telnet on port 53 so its working.

plz help
rgds
/M
Reply With Quote
  #14  
Old 17th March 2010, 19:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,444
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

If you changed the Nameserver of a domain, you have to wait up to 48 hours.

The dig command above does not query your local dns server, it querys any dns server. If you want to test if your local dns server is configured correctly, run the command:

dig @localhost domain.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #15  
Old 26th March 2010, 09:48
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default same problem

Hi again.

I got no answer from my DNS server from the Internet, it answer correctly when i run "dig @localhost mydomain.com"

but if i run nslookup mydomain.com i got no answer (cant find the domain)

plz help =)
rgds
M
Reply With Quote
  #16  
Old 26th March 2010, 13:03
zepx zepx is offline
Junior Member
 
Join Date: Feb 2010
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Use http://www.yougetsignal.com/tools/open-ports/

check port 53. Is it opened? If you have your firewall off, and yet port 53 does not respond, it means that BIND is not listening to port 53. I'm also facing this problem at the moment.

EDIT: I've solved my problem.

I'm using Ubuntu 9.10

1. First use "netstat -an" without quotes and check and see if 0.0.0.0:53 exists. I found out that it's using 127.0.0.1:53 which was not correct.
2. I changed /etc/bind/named.conf.options and had it looked something like below,

Code:
options {
        directory "/var/cache/bind";

        // If there is a firewall between you and nameservers you want
        // to talk to, you may need to fix the firewall to allow multiple
        // ports to talk.  See http://www.kb.cert.org/vuls/id/800113

        // If your ISP provided one or more IP addresses for stable
        // nameservers, you probably want to use them as forwarders.
        // Uncomment the following block, and insert the addresses replacing
        // the all-0's placeholder.

        // forwarders {
        //      0.0.0.0;
        // };

        auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { ::1; };
        allow-recursion {
                0.0.0.0;
                };
        query-source port 53;
};
3. Restart BIND

Regards,
Zepx

Last edited by zepx; 26th March 2010 at 13:19.
Reply With Quote
  #17  
Old 26th March 2010, 15:43
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default same same

Hi, sorry by i dont got "Bind" installed this is "Installing MyDNS-NG & MyDNSConfig 3 On Debian Lenny" installation and say nothing about BIND

I try netstat -an and it type med the correct IP:53 and 127.0.0.1:53

i already got 3 public BIND servers and they works fine.

I will go to MyDNSConfig if i get it to work but i got problems whit that =)

thanks
Reply With Quote
  #18  
Old 26th March 2010, 15:45
zepx zepx is offline
Junior Member
 
Join Date: Feb 2010
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok fine, but I think by default all DNS servers listen at port 53.

127.0.0.1:53 is not correct, and I don't think it will be answering any of your DNS Queries. Therefore, you need to make it to 0.0.0.0:53.

Figure it out for MyDNSConfig as even the latest ISPConfig 3.0.2.0+ has already started using BIND.
Reply With Quote
  #19  
Old 26th March 2010, 16:27
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default same same same

Hi again,

I checkt my other BIND servers and none of them had 0.0.0.0:53 only
localIP:53 and 127.0.0.1:53

i also got the latest stable version. and no luck =)
Reply With Quote
  #20  
Old 26th March 2010, 16:29
zepx zepx is offline
Junior Member
 
Join Date: Feb 2010
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Then have you tried the link I gave you? Have you tried checking whether port 53 is blocked?

Check them on all of your other servers as well. If they are opened, then it's really strange for me.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
email / out of office / auto answer captnnuss Installation/Configuration 5 11th March 2010 09:29
Install Choice and Why..Sorry for the length! happz Installation/Configuration 19 26th October 2008 04:03
How used differently my file php.ini misterm Installation/Configuration 7 9th June 2008 19:44
How to harden a ldirector? P Lao Server Operation 4 2nd July 2006 06:00
Fedora 4 TPS mail.domain.com does not answer anymore Hagforce HOWTO-Related Questions 3 24th February 2006 12:10


All times are GMT +2. The time now is 16:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.