Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th March 2010, 01:16
dpicella dpicella is offline
Senior Member
 
Join Date: Apr 2009
Posts: 116
Thanks: 9
Thanked 8 Times in 7 Posts
Default Paralyzed by "open_basedir restriction in effect"

I know this issue has been posted, but something is strange here.

I have 2 files:

index.php
Code:
<?
  include('include.php');
?>
include.php
Code:
  phpinfo();
I get ...


Code:
Warning: include() [function.include]: open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/sitename.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin) in /var/www/clients/client1/web1/web/index.php on line 3

Fatal error: Can't load include.php, open_basedir restriction. in /var/www/clients/client1/web1/web/index.php on line 3
The included file is clearly within the allowed paths ... so what's wrong? Weird!

This is a fresh install of ispconfig 3 on a Fedora 12 machine.
Reply With Quote
Sponsored Links
  #2  
Old 16th March 2010, 08:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Which PHP method do you use? Try to use php-fcgi + suexec.

Also you can try to change the open basedir path to:

/var/www/clients/client1/web1:/var/www/sitename.com:/usr/share/php5:/tmp:/usr/share/phpmyadmin
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th March 2010, 18:49
dpicella dpicella is offline
Senior Member
 
Join Date: Apr 2009
Posts: 116
Thanks: 9
Thanked 8 Times in 7 Posts
Default

The only php method that seems to work is cgi

Looking at /usr/local/ispconfig/server/conf/vhost.conf.master

I noticed that only the standard php method includes the open_basedir paths.

I put the following lines in vhost.conf.master under the cgi method and then set the path string to "none"

That is the only thing that seems to work

Code:
    php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@<tmpl_var name='domain'>"
    php_admin_value upload_tmp_dir <tmpl_var name='document_root'>/tmp
    php_admin_value session.save_path <tmpl_var name='document_root'>/tmp
<tmpl_if name='security_level' op='==' value='20'>
    php_admin_value open_basedir <tmpl_var name='php_open_basedir'>
</tmpl_if>
???
Reply With Quote
  #4  
Old 17th March 2010, 19:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Please make sure that you disabled selinux in Fedora 12.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th March 2010, 20:29
dpicella dpicella is offline
Senior Member
 
Join Date: Apr 2009
Posts: 116
Thanks: 9
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by till View Post
Please make sure that you disabled selinux in Fedora 12.
selinux has already been disabled. Any other thoughts?

Code:
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#       enforcing - SELinux security policy is enforced.
#       permissive - SELinux prints warnings instead of enforcing.
#       disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#       targeted - Targeted processes are protected,
#       mls - Multi Level Security protection.
SELINUXTYPE=targeted
Reply With Quote
  #6  
Old 20th March 2010, 08:09
rudisoft rudisoft is offline
Junior Member
 
Join Date: Jan 2010
Posts: 3
Thanks: 1
Thanked 2 Times in 1 Post
 
Default

Hi everyone!

Having the exact same problem unfortunately...
I'm using ISPConfig 3.0.6 on a Fedora 12 perfect server setup.
Disabling open_basedir seems to be the only solution so far.

Hope someone will figure this one out
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fixing open_basedir restriction runbuck General 2 28th December 2009 20:57


All times are GMT +2. The time now is 02:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.