Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th March 2010, 12:31
bn61 bn61 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Default setting up chrooted ssh user, jailkit installed after ispconfig

I want to set up a chrooted ssh user. Everytime I try to login remotely the session gets closed immediately after the login.
I guess it has something to do that I installed jailkit (2.11) after I installed ISPConfig3. (It's working on another machine where I did it right.)
Code:
ispconfig_update.sh
... was not enough.
Any suggestions on how to fix that?
Reply With Quote
Sponsored Links
  #2  
Old 15th March 2010, 14:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

You have to update ispconfig again and select to reconfigure services. Use the manual update instructions for this.

Then delete the chrooted ssh user that you created before and recreate it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 15th March 2010, 14:56
bn61 bn61 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Default

I am drawing a blank on this. What do you mean by
Quote:
You have to update ispconfig again and select to reconfigure services. Use the manual update instructions for this.
?
Reply With Quote
  #4  
Old 15th March 2010, 15:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

Take a look in the ispconfig release notes, they contain a section called manual update instructions as you can not do the update with the ispconfig_update.sh again if the version installed on your system is the same then the version used for updating.

http://www.howtoforge.com/forums/showthread.php?t=44013
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 15th March 2010, 15:38
bn61 bn61 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Default

Still no luck.
Reply With Quote
  #6  
Old 15th March 2010, 15:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

Then you might have to recreate the website. The initail ssh jail for the website is created when you created the first ssh chrooted user. If jailkit was not installed properly before, this jail can be broken and jailing will not work then.

I recommend that you first test the jailkit functionality by creating a new dummy site with a domain like example.tld and then create a new jailed ssh user in this site. Wait a few minutes and if the jail works, then recreate the initial site.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
bn61 (15th March 2010)
  #7  
Old 15th March 2010, 17:19
bn61 bn61 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Default It works!

I had to set up website and client new.

Thanks for your help!
Reply With Quote
  #8  
Old 5th May 2011, 16:02
lolo6tm lolo6tm is offline
Junior Member
 
Join Date: Mar 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Jailkit SSH User do not work as expected... (ISPConfig 3.°.3.3)

If you create zan SSH/Jailkit user using ISPConfig admin account it won't work, at least for me. You got to create it using the reseller/client account which owns the concerned website.

Hope it will help ...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
ISPConfig installation into multiple OpenVZ containers letezo Installation/Configuration 11 3rd March 2009 22:47
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
Users and websites aren't created Glorfindel Installation/Configuration 9 23rd February 2006 04:20


All times are GMT +2. The time now is 09:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.