Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th March 2010, 23:50
rukus77 rukus77 is offline
Member
 
Join Date: Apr 2009
Posts: 33
Thanks: 7
Thanked 4 Times in 4 Posts
Default SMTP issues after upgrading to 3.0.2 - Dovecot related?

Hi,

I just upgraded from 3.0.16 to 3.0.2 and am no longer able to send or receive emails. I see that dovecot support was added and this may be causing issues with my existing config.

Should I install dovecot or can I get my config back to default? I originally used perfect setup for CentOS 5.3.

I now get the following errors;

Mar 11 16:24:59 ns3 postfix/smtpd[8820]: warning: SASL: Connect to private/auth failed: No such file or directory
Mar 11 16:24:59 ns3 postfix/smtpd[8820]: fatal: no SASL authentication mechanisms
Mar 11 16:24:59 ns3 postfix/smtpd[8822]: warning: SASL: Connect to private/auth failed: No such file or directory
Mar 11 16:24:59 ns3 postfix/smtpd[8822]: fatal: no SASL authentication mechanisms
Mar 11 16:25:00 ns3 postfix/master[8151]: warning: process /usr/libexec/postfix/smtpd pid 8820 exit status 1
Mar 11 16:25:00 ns3 postfix/master[8151]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Mar 11 16:25:00 ns3 postfix/master[8151]: warning: process /usr/libexec/postfix/smtpd pid 8822 exit status 1

I have in my main.cf;

# grep smtpd /etc/postfix/main.cf
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_use_tls = yes
smtpd_tls_security_level = may
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth

and;

# grep dovecot /etc/postfix/main.cf
virtual_transport = dovecot
dovecot_destination_recipient_limit = 1

Thanks guys,
Mike
Reply With Quote
Sponsored Links
  #2  
Old 12th March 2010, 00:02
rukus77 rukus77 is offline
Member
 
Join Date: Apr 2009
Posts: 33
Thanks: 7
Thanked 4 Times in 4 Posts
Default

Guys,

Just an FYI, in case anyone runs into this and did not backup their main.cf...

remove or comment out the dovecot references;

#smtpd_sasl_type = dovecot
#smtpd_sasl_path = private/auth
#dovecot_destination_recipient_limit = 1

and change the transport back to;

virtual_transport = maildrop

I am sending/receiving emails again.

Thanks,
Mike

Last edited by rukus77; 12th March 2010 at 00:13.
Reply With Quote
The Following User Says Thank You to rukus77 For This Useful Post:
rlischer (21st July 2010)
  #3  
Old 12th March 2010, 10:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

Looks as if you had dovecot and courier installed on your system at the same time as the installer detected the dovecot binaries while your system used courier. As dovecot was not supported by 3.0.1.6, your system must use courier and not dovecot. Please uninstall dovecot with yum and make sure that only courier is installed, then do the update again by following the manual update instructions from the release notes.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
rukus77 (12th March 2010)
  #4  
Old 12th March 2010, 18:41
rukus77 rukus77 is offline
Member
 
Join Date: Apr 2009
Posts: 33
Thanks: 7
Thanked 4 Times in 4 Posts
 
Default

Thanks Till. That's what it was.

Yeah, I realized that after my post and corrected the issue to allow send/receive, but did not re-run the update. I will do that now.

Thanks again,
Mike
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Postfix can't received email from exterior astra2000 Server Operation 5 17th October 2009 23:26
Postfix issues NewMee Installation/Configuration 7 20th April 2009 18:52
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47


All times are GMT +2. The time now is 06:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.