#11  
Old 12th March 2010, 11:43
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Hi Till,

Thanks for your explanation.
What you say can be the reason indeed.
I will do the upgrade not now but tonight and report how i'm doing.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
Sponsored Links
  #12  
Old 12th March 2010, 18:00
neuromystical neuromystical is offline
Junior Member
 
Join Date: Jun 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

From United Stated --> Columbus, Ohio

I figured out how to fix my issues and rollback my upgrade.

1. My database was completely empty(no tables existed either)
2. Had to restore the table structure from my 3.0.1.6 from original 3.0.1.6 install/sql folder
3. Had to truncate all the tables in it
4. Restored my SQL backup before the upgrade.
5. Tested and everything works!

Could have done this:
Now I could have restored my VMWARE snapshot image, but wanted to figure out why this upgrade failed the way it did.

Just took time to understand. My log files show nothing as well.

Thanks
Eric



Quote:
Originally Posted by Hans View Post
Please be patient, as the developers need to find a solution. I don't know where you're from, but ISPConfig has it's origin in Germany, during your post it was there in the middle of the night.

The error occurred instantly after giving the MySQL password. After that the upgrade was aborted. Nothing happened to your existing MySQL database.
So don't worry about that. There will be a solution soon!
Reply With Quote
  #13  
Old 12th March 2010, 18:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

This can only happen if you modified a table in ispconfig or added an additional table into the same database which made the table structure of your data incomtaoble with the new ispconfig version. To fix this, undo the changes that you did on the tables e.g. delete the fields ortables that you added before you do an update.

You can find the incompatible tables by creating a new temporary mysql database, then load the database dump from the ispconfig_install/install/sql/ispconfig3.sql into this database, truncate all tables. then export all data from your current ispconfig database and try to reimport it in our temporary database.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #14  
Old 12th March 2010, 18:28
neuromystical neuromystical is offline
Junior Member
 
Join Date: Jun 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had made no modifications personally and I am the only admin for my servers. Could it have occurred if the install was ran twice? the only thing I do is update my Ubuntu server once a week.

In any case it is resolved




Quote:
Originally Posted by till View Post
This can only happen if you modified a table in ispconfig or added an additional table into the same database which made the table structure of your data incomtaoble with the new ispconfig version. To fix this, undo the changes that you did on the tables e.g. delete the fields ortables that you added before you do an update.

You can find the incompatible tables by creating a new temporary mysql database, then load the database dump from the ispconfig_install/install/sql/ispconfig3.sql into this database, truncate all tables. then export all data from your current ispconfig database and try to reimport it in our temporary database.
Reply With Quote
  #15  
Old 12th March 2010, 19:34
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Thumbs up

Quote:
Originally Posted by till View Post
I guess I see the problem now. As you did not used the server before the update, the dumped db is just below the minimum size that the updater expects. If you would just have created a website or two, the update should have run trough.


Please check the content of the existing_db.sql file. If it looks as it contains all the data of the dbispconfig database, then delete the existing_db.sql file, edit the update.php script in line 152 and change

if(filesize('existing_db.sql') < 60000)

to:

if(filesize('existing_db.sql') < 30000)

Then run update.php again to do the update. This is the solution for your case and not nescessarily the solution for the problems of the other posters.

So @everyone else in this thread: do the manual update procedure and then take a look at the size of the existing_db.sql file and its content. If it seems to contain all the data from the dbispconfig database, then proceed as I suggested to Hans in this post.

I will set the limit for the size check to 30000 in future updates.
Thanks Till for your sharp view!
I just updated all my ISPConfig3 servers (6 in total) without any problem.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #16  
Old 18th March 2010, 22:05
nokia80 nokia80 is offline
HowtoForge Supporter
 
Join Date: Apr 2009
Posts: 183
Thanks: 30
Thanked 2 Times in 2 Posts
Send a message via Skype™ to nokia80
Default

hi all

where is update.php to changes 6000 in 3000



thanks a lot michael
Reply With Quote
  #17  
Old 19th March 2010, 09:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
 
Default

It is in the ispconfig tar.gz file (install_ispconfig/install/update.php).
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
ISPconfig 3 strange problem after update 3.0.16 sheshes Installation/Configuration 3 30th November 2009 07:52
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
ISPconfig problem after update matej Installation/Configuration 2 19th November 2008 13:25
php4 problem after update Aloa Installation/Configuration 2 14th February 2008 12:23


All times are GMT +2. The time now is 23:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.