#1  
Old 11th March 2010, 21:42
shoevring shoevring is offline
Member
 
Join Date: Feb 2010
Posts: 71
Thanks: 1
Thanked 2 Times in 2 Posts
Default Great or not!

Hello every one..

I just updated my mainweb server with 3.0.2,

Before i start, you should get some info about my installation.

I have 3 servers.

Server 1: mainweb > To controlpanel
Server 2: web1 > Webserver1 without controlpanel
Server 3: web2 > Webserver2 without controlpanel

I just updated mainweb, but now i can't login with my logins and no off my clients can..

Where is nothing in sys_user(mysql-table) but my clients is still there, but can't login.

All webpages, mails works fine on web1 and web2..

In installation i just followed the installation guide..

I'm very in stock here.. Any some can help me to fix this problem?
Reply With Quote
Sponsored Links
  #2  
Old 12th March 2010, 11:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

If you use a multiserver system, yoiu have to update the slave servers first and then update the amster server.

Also it looks like you have modified the sys_user table. Did you change a colum or added a column in this database table or any other table on the mainweb server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th March 2010, 18:17
shoevring shoevring is offline
Member
 
Join Date: Feb 2010
Posts: 71
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till View Post
If you use a multiserver system, yoiu have to update the slave servers first and then update the amster server.

Also it looks like you have modified the sys_user table. Did you change a colum or added a column in this database table or any other table on the mainweb server?
Yes i have a multiserver system, but why did the server delete everything? Domains, subdomains, mails, everything besides client information in client table..?

No, i did't - it was a clean ispconfig.
Reply With Quote
  #4  
Old 12th March 2010, 18:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

The server did not delete everything, the update was just not able to load the database content into the table structure. The problem is that the structure of your database content does not match the ispconfig database structure. Did you install any third party plugins like the akTicket extension for ispconfig?

You can find a backup of the database content in the root folder as .sql file. Please load this database content back into the empty database with phpmyadmin. If phpmyadmin shows an error, please post it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 12th March 2010, 19:20
shoevring shoevring is offline
Member
 
Join Date: Feb 2010
Posts: 71
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till View Post
The server did not delete everything, the update was just not able to load the database content into the table structure. The problem is that the structure of your database content does not match the ispconfig database structure. Did you install any third party plugins like the akTicket extension for ispconfig?

You can find a backup of the database content in the root folder as .sql file. Please load this database content back into the empty database with phpmyadmin. If phpmyadmin shows an error, please post it.
No, and nice! but there is an error:

Quote:

Error

SQL-request:

INSERT INTO `client` (`client_id`, `sys_userid`, `sys_groupid`, `sys_perm_user`, `sys_perm_group`, `sys_perm_other`, `company_name`, `contact_name`, `street`, `zip`, `city`, `state`, `country`, `telephone`, `mobile`, `fax`, `email`, `internet`, `icq`, `notes`, `default_mailserver`, `limit_maildomain`, `limit_mailbox`, `limit_mailalias`, `limit_mailforward`, `limit_mailcatchall`, `limit_mailrouting`, `limit_mailfilter`, `limit_fetchmail`, `limit_mailquota`, `limit_spamfilter_wblist`, `limit_spamfilter_user`, `limit_spamfilter_policy`, `default_webserver`, `limit_web_ip`, `limit_web_domain`, `web_php_options`, `limit_web_subdomain`, `limit_web_aliasdomain`, `limit_ftp_user`, `limit_shell_user`, `ssh_chroot`, `default_dnsserver`, `limit_dns_zone`, `limit_dns_record`, `default_dbserver`, `limit_database`, `limit_cron`, `limit_cron_type`, `limit_cron_frequency`, `limit_client`, `parent_client_id`, `username`, `password`, `language`, `usertheme`, `template_master`, `template_additional`, `[...]

MySQL returnerede: Dokumentation
#1062 - Duplicate entry '4' for key 1
Reply With Quote
  #6  
Old 12th March 2010, 19:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Ok. Maybe its a database corruption in this case as mysql seemed to have created two dupliacte records in a auto increment column which should not be possible. You can try to remove all indexes from the client table and then try to import the dump again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 12th March 2010, 20:38
shoevring shoevring is offline
Member
 
Join Date: Feb 2010
Posts: 71
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till View Post
Ok. Maybe its a database corruption in this case as mysql seemed to have created two dupliacte records in a auto increment column which should not be possible. You can try to remove all indexes from the client table and then try to import the dump again.

Great man! after i delete dumps in client, an error from client_template, countrys and more comes..

I think i want to start over..

Are the 3.0.2 the same install requirements like 3.1.6 ?
Reply With Quote
  #8  
Old 12th March 2010, 21:02
shoevring shoevring is offline
Member
 
Join Date: Feb 2010
Posts: 71
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by shoevring View Post
Great man! after i delete dumps in client, an error from client_template, countrys and more comes..

I think i want to start over..

Are the 3.0.2 the same install requirements like 3.1.6 ?
And.. How do i backup my clients mail? When i want to move it to the new server?
Reply With Quote
  #9  
Old 12th March 2010, 21:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Quote:
Great man! after i delete dumps in client, an error from client_template, countrys and more comes..
1) Make a backup of the broken database.
2) Truncate (empty) all database tables in this database but dont delete them.
3) Try to load the database dump that was made as ispconfig was updated into the database.

Quote:
Are the 3.0.2 the same install requirements like 3.1.6 ?
Yes.

But the software install is not broken, its just a problem with the database that should be fixable. So I do not recommend to start over.

Quote:
And.. How do i backup my clients mail? When i want to move it to the new server?
make a tar.gz of the cmail directory. e.g.

tar pcfz email_backup.tar.gz /var/vmail
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 13th March 2010, 20:04
shoevring shoevring is offline
Member
 
Join Date: Feb 2010
Posts: 71
Thanks: 1
Thanked 2 Times in 2 Posts
 
Default

Quote:
Originally Posted by till View Post
1) Make a backup of the broken database.
2) Truncate (empty) all database tables in this database but dont delete them.
3) Try to load the database dump that was made as ispconfig was updated into the database.



Yes.

But the software install is not broken, its just a problem with the database that should be fixable. So I do not recommend to start over.



make a tar.gz of the cmail directory. e.g.

tar pcfz email_backup.tar.gz /var/vmail
I think its better, i just installed the new serveres(all 3)

And i just try to overwrite mailboxes(I have already created them in ispconfig)

I took backup from my old mailserver(/var/vmail) and put it in the new mail server, but the squirrelmail can see the folders i have previously created, but cant open them, i try to run this command on the ssh: chown -r www-data:www-data /var/vmail but i think it not right.. So i tried again with postfix user, and now it cant connect("ERROR: Connection dropped by IMAP server.")

How can i get this to work corretly?

And thanks for your great help!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NEW INSTALL WORKS GREAT BUT a few issues webwork Installation/Configuration 4 18th April 2008 21:58
HowWill A Great Domain Name HelpMe? yumiko Smalltalk 2 14th May 2007 22:17
Ispconfig - great app - 2 probs - please help n3m3s1s4u Installation/Configuration 1 13th January 2007 16:25
Great FREE software to document your entire IT infrastructure itguy321 Server Operation 9 2nd August 2006 09:41
All time great howto's linutzy Suggest HOWTO 8 27th December 2005 15:03


All times are GMT +2. The time now is 07:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.