Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th March 2010, 20:17
Per_Gustafsson Per_Gustafsson is offline
Junior Member
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default apt-get install ncftp (failed)

When running
apt-get install ncftp

Package ncftp is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ncftp has no installation candidate


My Sources.list is

deb ftp://ftp.debian.org/debian lenny contrib main
deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib


I need ncftp to create mysql backups so i hope someone can help me out on this matter.
Reply With Quote
Sponsored Links
  #2  
Old 9th March 2010, 10:08
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

This makes me wonder a bit, as according to packages.debian.org a package exists: http://packages.debian.org/search?ke...le&section=all

what does
Quote:
aptitude search ncftp
tell you? Does it find something? If so you should be able to install it. Otherwise you might try to download it from the source mentioned above.
Reply With Quote
  #3  
Old 9th March 2010, 11:29
Per_Gustafsson Per_Gustafsson is offline
Junior Member
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Ben.

Thanks for helping out.

Code:
aptitude search ncftp
gives me

Quote:
p ncftp - A user-friendly and well-featured FTP client

Regarding installation of the source i would like to keep it simple by using Apt-get for installation and removal since i am not that well orientated with Building and compiling.
Reply With Quote
  #4  
Old 9th March 2010, 15:10
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

afaik if you manually install the downloaded deb according to your debian version, this should be added to the dpkg package list and thus be updated by apt(itude) in the future in case the known repos contain it.

Anyhow, as aptitude search did find it, just try
Quote:
aptitude install ncftp
Reply With Quote
  #5  
Old 9th March 2010, 15:39
Per_Gustafsson Per_Gustafsson is offline
Junior Member
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
www:~# aptitude install ncftp

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
No candidate version found for ncftp
No candidate version found for ncftp
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
Reply With Quote
  #6  
Old 9th March 2010, 16:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's the output of
Code:
apt-cache policy ncftp
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 9th March 2010, 16:41
Per_Gustafsson Per_Gustafsson is offline
Junior Member
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
www:~# apt-cache policy ncftp

Quote:
ncftp:
Installed: (none)
Candidate: (none)
Version table:
2:3.2.1-1 0
-1 ftp://ftp.debian.org lenny/main Packages
Reply With Quote
  #8  
Old 10th March 2010, 15:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

That's really strange. Can you run
Code:
aptitude update
and try again?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SugarCRM Install on ISPConfig3 w/ SuPHP clucena Installation/Configuration 1 9th February 2010 10:29
Sites stopped working Toucan Installation/Configuration 21 4th January 2010 00:27
Debian Lenny apt-get update failed to fetch qriz Installation/Configuration 3 31st October 2009 23:19
Spamassassin not working hairydog2 General 7 12th July 2008 22:15
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 17:30


All times are GMT +2. The time now is 05:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.