Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th March 2010, 02:04
bswinnerton bswinnerton is offline
Senior Member
 
Join Date: Jul 2007
Location: Connecticut, US
Posts: 502
Thanks: 51
Thanked 17 Times in 14 Posts
Default symlink to roundcube webmail displays "No input file specified."

symlink to roundcube webmail displays "No input file specified."

I've created a symlink to the /webmail directory on my main website on all of my client's websites. It works fine on the main website, but on all of the client sites it says: "No input file specified."
Reply With Quote
Sponsored Links
  #2  
Old 6th March 2010, 13:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Are symlinks allowed for the virtual hosts?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th March 2010, 22:32
bswinnerton bswinnerton is offline
Senior Member
 
Join Date: Jul 2007
Location: Connecticut, US
Posts: 502
Thanks: 51
Thanked 17 Times in 14 Posts
Default

I'm not sure, here is what's in mysite.com.vhost file:

<Directory /var/www/criticalwire.com/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web1/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>

Last edited by bswinnerton; 6th March 2010 at 22:45.
Reply With Quote
  #4  
Old 7th March 2010, 16:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Options FollowSymLinks
Hm, symbolic links are allowed... Are there any errors in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th March 2010, 17:59
bswinnerton bswinnerton is offline
Senior Member
 
Join Date: Jul 2007
Location: Connecticut, US
Posts: 502
Thanks: 51
Thanked 17 Times in 14 Posts
Default

Here we go:

Code:
[Sun Mar 07 10:55:25 2010] [notice] mod_fcgid: call /var/www/site1.com/web/webmail/index.php with wrapper /var/www/php-fcgi-scripts/web7/.php-fcgi-starter
..not that I can make any sense out of it.
Reply With Quote
  #6  
Old 8th March 2010, 14:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Oh, you're using mod_fcgid. I guess it is a permissions problem because /var/www/site1.com/web/webmail/index.php isn't owned by the correct user and group.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 8th March 2010, 15:55
bswinnerton bswinnerton is offline
Senior Member
 
Join Date: Jul 2007
Location: Connecticut, US
Posts: 502
Thanks: 51
Thanked 17 Times in 14 Posts
Default

Hmm, well who should it be owned by?

I wasn't unaware that I was using the mod to be honest.

Last edited by bswinnerton; 8th March 2010 at 16:00.
Reply With Quote
  #8  
Old 9th March 2010, 16:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

The problem is that each mod_fcgid web site requires another user and group. I think it's better to use mod_php in this case.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 9th March 2010, 18:00
bswinnerton bswinnerton is offline
Senior Member
 
Join Date: Jul 2007
Location: Connecticut, US
Posts: 502
Thanks: 51
Thanked 17 Times in 14 Posts
Default

Still no luck, same problem when I changed it to mod_php.

EDIT: Forgot to add it to mod_php to the client. But now I'm getting a screen when trying to view the webmail page on the client.

Last edited by bswinnerton; 9th March 2010 at 19:23.
Reply With Quote
  #10  
Old 9th March 2010, 19:24
bswinnerton bswinnerton is offline
Senior Member
 
Join Date: Jul 2007
Location: Connecticut, US
Posts: 502
Thanks: 51
Thanked 17 Times in 14 Posts
 
Default

Quote:
Originally Posted by bswinnerton View Post
Still no luck, same problem when I changed it to mod_php.

EDIT: Forgot to add it to mod_php to the client. But now I'm getting a screen when trying to view the webmail page on the client.
With the following in the error.log of the client:

Code:
[Tue Mar 09 12:23:13 2010] [error] [client 192.168.1.50] PHP Fatal error:  Unknown: Failed opening required '/var/www/clientsite.com/web/webmail/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 21:17
Can't access to my website - after install problem pallermo Installation/Configuration 18 4th June 2010 14:29
post fix error after a year aberrio Server Operation 5 5th May 2009 22:33
Opening TPC ports thehappyappy Installation/Configuration 12 7th May 2008 19:39
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 04:40


All times are GMT +2. The time now is 22:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.