#1  
Old 7th March 2010, 20:14
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 41 Times in 34 Posts
Default Possible DNS Mail problem

I'm runing config3 on lenny as per perfect guide and the name server set up as per the schlundtech guide

Mail mostly works fine. I can send mail to googlemail and yahoo without it landing in junk folders.

Recently however I've had a trouble sending to a couple of domains. I received this mail back:

Quote:
This is the mail system at host badbuntu.mydomain.co.uk.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<Steve@anotherdomain.com>: host mx.anotherdomain.com[82.140.75.150] said: 554
<93-97-188-1.zone5.bethere.co.uk[93.97.188.1]>: Client host rejected:
Please set up DNS for your mail host right, use SMTP server of your ISP, or
be authorized to send message here /ip/ (in reply to RCPT TO command
the other rejection I got a couple of days ago was from a netgear email.. as below:

Quote:
This is the mail system at host badbuntu.mydomain.co.uk.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<level2support@netgear.com>: host mailgw1.netgear.com[12.151.34.250] said: 550
Error: content rejected (in reply to end of DATA command)
The only thing that springs to mind, and this really is a guess, when i set up the name server records as per the guide, I couldn't work out how to create the SPF records in config3.

Any ideas much appreciated?
Reply With Quote
Sponsored Links
  #2  
Old 8th March 2010, 12:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Please check that you have a reverse record for your IP address tha points to the hostane of your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th March 2010, 12:43
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 41 Times in 34 Posts
Default

I don't have a ptr record for that domain. Is there an example I could follow? Should I make one for every zone that I host?

Although I've not got an entry for ptr I did get this back from intodns.com:

Quote:
Reverse MX A records (PTR) Your reverse (PTR) record:
1.188.97.93.in-addr.arpa*-> *93-97-188-1.zone5.bethere.co.uk
You have reverse (PTR) records for all your IPs, that is a good thing.
the domain in question is petbits.co.uk
Reply With Quote
  #4  
Old 8th March 2010, 13:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

You have to ask the provider that assigned you the IP to add or change the ptr record in his nameserver.

Quote:
Should I make one for every zone that I host?
No. PTR record dont have to be added in your zones, it has to be added in the dns server which is responsible for the IP address (the server of your internet provoder) and not the dns server that you use for your domains.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Toucan (12th March 2010)
  #5  
Old 8th March 2010, 14:26
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 41 Times in 34 Posts
Default

OK Thanks, so just to make sure I ask my ISP to the right thing I have to ask them to create a reverse dns record for my static IP to point to the name badbuntu.badbison.co.uk ? That is that name that I assigned my ISPConfig3 server when setting up. The name badbison.co.uk is also glued to my IP address in the registry for name server purpose.


David
Reply With Quote
  #6  
Old 9th March 2010, 16:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by Toucan View Post
I have to ask them to create a reverse dns record for my static IP to point to the name badbuntu.badbison.co.uk ?
That's right.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Toucan (12th March 2010)
  #7  
Old 12th March 2010, 00:12
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 41 Times in 34 Posts
 
Thumbs up Solved

Thanks guys

It took a while to get my ISP O2 to do it but eventualy get there. Problem is first level support don't understand DNS.

Q:
How do I stop mail getting bounced back because my server purports to be a different domain name to that which my ISP holds for my IP address?

A:
Ask your ISP to create a PTR (reverse lookup record) in their DNS records for your public IP.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 23:41
Sending emails with custom FROM email address merisor Installation/Configuration 4 8th February 2010 17:27
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 14:58
421 Unexpected failure Lizard King Installation/Configuration 20 7th July 2009 21:43
Problem with dcc-client installation (Postfix) swap-as Installation/Configuration 9 18th September 2008 21:47


All times are GMT +2. The time now is 19:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.