Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th April 2010, 08:20
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 210
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Question Umlaut problem on ISPConfig3 server

On the moment i'm busy to migrate all my websites from my ISPConfig2- to my ISPConfig3 servers.
Although it's a lot of work, everything goes well until now.

I've seen that my client used an umlaut on his website. This umlaut, which should be "" is displayed as "ü".

The DefaultCharset has been switched off on Debian Lenny.
The reason for this might be, that Apache is forced to use the characterset which is used in the header of the websites, like
"<meta http-equiv="Content-Type" content="text/html;>charset=iso-8859-1" />" for example.

In my browser, when i switch from iso-8859-1 to utf- encoding, the website appears well, as the "" appears well, but that's not what my client wants.

Can anyone advise me how to solve this problem.
(Because i did not have problems with my ISPConfig3 servers, my configuration files are still default).
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
Sponsored Links
  #2  
Old 10th April 2010, 19:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

You might try to set a default charset for this vhost e.g. by using a .htaccess file or add it in the apache directives field of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Hans (11th April 2010)
  #3  
Old 11th April 2010, 07:55
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 210
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
 
Default

Hi Till,
I've done the following:
Within ISPConfig3, i added the following tot the "Options" tab of the website:

Option: Allow Override: All
Apache directives: AddDefaultCharset UTF-8

This works for me!

Thanks for your help.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
ISPConfig3: Problem with Server Config and network interfaces tkalatz Installation/Configuration 4 21st May 2010 16:49
ISPconfig3 and DNS server for internal network Mitz Server Operation 0 12th November 2009 11:31
Reciving mail problem kaliszakpl Installation/Configuration 1 18th March 2008 10:15
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 16:30


All times are GMT +2. The time now is 05:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.