Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th June 2012, 15:34
Davide Davide is offline
Senior Member
 
Join Date: Jul 2006
Posts: 123
Thanks: 16
Thanked 7 Times in 6 Posts
Default Problem with server.php

Hi

This morning my "server.php" hanged up, and now users cannot update things in ispconfig3 panel.

These are the lasts lines before hagnup:

Code:
11.06.2012-09:32 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock  
11.06.2012-09:32 - DEBUG - Found 2 changes, starting update process.
11.06.2012-09:32 - DEBUG - Calling function 'user_update' from plugin 'mail_plugin' raised by event 'mail_user_update'.
11.06.2012-09:32 - DEBUG - Updated Maildir quota: su -c 'maildirmake -q 367001600S /var/vmail/foodomain.com/administracion' vmail
11.06.2012-09:32 - DEBUG - Calling function 'update' from plugin 'maildrop_plugin' raised by event 'mail_user_update'.
11.06.2012-09:32 - DEBUG - Processed datalog_id 14207
11.06.2012-09:32 - DEBUG - Calling function 'user_update' from plugin 'mail_plugin' raised by event 'mail_user_update'.
11.06.2012-09:33 - DEBUG - There is already an instance of server.php running. Exiting.
11.06.2012-09:34 - DEBUG - There is already an instance of server.php running. Exiting.
11.06.2012-09:35 - DEBUG - There is already an instance of server.php running. Exiting.
I've already tried to kill server.php and deleting lock file, but server.php entered and got hung again

Code:
11.06.2012-11:28 - DEBUG - There is already a lockfile set. Waiting another 10 seconds...
11.06.2012-11:28 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
11.06.2012-11:28 - DEBUG - Found 1 changes, starting update process.
11.06.2012-11:28 - DEBUG - Calling function 'user_update' from plugin 'mail_plugin' raised by event 'mail_user_update'.
11.06.2012-11:29 - DEBUG - There is already an instance of server.php running. Exiting.
As you can see, loglevel is already debug

Does anyone know what could be wrong with this job?
Is is possible to simply delete it from queue?
Reply With Quote
Sponsored Links
  #2  
Old 11th June 2012, 15:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Seems as if the PHP process dies. Have you changed any php.ini settings on yourserveryestaerday, especially disabling any classes or functions?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 11th June 2012, 16:15
Davide Davide is offline
Senior Member
 
Join Date: Jul 2006
Posts: 123
Thanks: 16
Thanked 7 Times in 6 Posts
Default

I've only changed memcache allocated memory from 256 to 384 MB, but it shouldn't have influence in php. Server hasn't memory problems.

Process is still in machine:

Code:
# ps uaxw |grep server.php
root       896  0.0  0.2 223600 19504 ?        S    13:10   0:00 /usr/bin/php -q /usr/local/ispconfig/server/server.php
Does this mean that process hasn't died?
Reply With Quote
  #4  
Old 12th June 2012, 00:08
Davide Davide is offline
Senior Member
 
Join Date: Jul 2006
Posts: 123
Thanks: 16
Thanked 7 Times in 6 Posts
 
Default

I've solved it

It was a mail directory wrong permission problem. (/var/vmail/domain/user)

I chowned it to vmail, and command finished ok.

Thanks anyway.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Courier Imap is not working HellMind General 5 12th April 2012 01:04
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
BIG Problem Postfix issue admins Installation/Configuration 11 13th November 2009 10:05
postfix mysql on fedora core5 igongora Installation/Configuration 7 17th April 2007 04:40


All times are GMT +2. The time now is 04:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.