#1  
Old 2nd March 2010, 17:25
barney.parker barney.parker is offline
Junior Member
 
Join Date: Jun 2007
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help! Broken Exim4

Hi,

I have been asked to fix an unstable server, and am having some big issues with exim4!

It seems that the local IT guy in his wisdom decided to apt-get remove exim4.

To compound the problem he then manually deleted various folders named exim4, and also the /etc/init.d/exim4 file.

After many attempts to restore the situation i have managed to get exim to reinstall, but still don't appear to have the /etc/init.d/exim4 file, so i can't actually start exim4!

To fix initially i used aptitude purge to remove all the components of exim4. I then tried to apt-get install exim4 but got loads of errors, so in the end had to apt-get install exim4-daemon-light, then apt-get install exim4.

this then kicked off the dpkg-reconfigure exim4-config as expected.

As far as i can see, the whole thing seems to be there, but with the init.d file missing i am pretty much stuck!!!

Does anyone have any ideas how i can either A) purge exim4 so completely it was like it was never there in the first place, or B) fix the missing file(s?).

Alternatively can anyone suggest an MTA that can be set up to send via a smart-host and will be really simple to set up? (i'm not too well clued up on mail servers!) It only needs to be able to make the PHP function "mail" work correctly sending to external email addresses...

Thanks in advance...
Reply With Quote
Sponsored Links
  #2  
Old 2nd March 2010, 20:48
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

I guess you use debian?
in this case you might download the exim4-base package manually from the debain page as the init-script should be in there: http://packages.debian.org/lenny/i38...-base/filelist
Reply With Quote
  #3  
Old 2nd March 2010, 21:06
barney.parker barney.parker is offline
Junior Member
 
Join Date: Jun 2007
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Ben: Good thinking!!!! I've now done that and the exim lives again!

Now i just need to find out how it was all configured!!!!

Thanks for all your help, it may have been simple but i just didn't think of it!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
dk-filter / sendmail / centos ALMOST working but broken pipe to socket? Please help kinesis Installation/Configuration 4 6th April 2009 20:54
Sendmail / DomainKeys Integration / CENTOS - mysterious broken pipe error? Plz help! kinesis Server Operation 1 6th April 2009 14:14
bzcat broken pipe after ISPConfig update jdubuke Installation/Configuration 3 11th July 2007 16:57
SVN Broken, database sql dump is broken? danf.1979 Developers' Forum 4 16th February 2007 11:26
How work postfix, exim4 and courier together? tom General 3 10th April 2006 22:45


All times are GMT +2. The time now is 13:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.