Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > MyDNSConfig > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 13th April 2007, 16:16
michaelkjohnson michaelkjohnson is offline
Junior Member
 
Join Date: May 2006
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
Arrow

Quote:
Originally Posted by SyberWizard
...Nowhere however, do I see anything for accessing MyDNS or MyDNSConfig in order to actually use the interface.
The main page for the system is a "landing page" that links to two URLs: the rPath Appliance Platform web management console, and the MyDNSConfig interface. Assuming that your system is called "ns.example.com", point your browser at "http://ns.example.com/" and you'll see both links.
Reply With Quote
Sponsored Links
  #22  
Old 13th April 2007, 20:26
SyberWizard SyberWizard is offline
Junior Member
 
Join Date: Mar 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks, that did it. It appears that port 80 does not work at all until after completing the rAA setup. It never occurred to me to go back and check it after setup!

So, from the observations of a novice. There should be some guidance that:

need to turn off the firewall, as there is no selection for allowing DNS communications, OR add DNS ports to the firewall (better solution).

need to install the Everything selection in order to get MyDNS loaded. Can Everything be set as the default selection?

It would be great if that last screen mentioned that, in order to access the rAA setup, one must use port 8003/8004, and after completing setup, go back to the standard port 80.

My final question, and I do not know if this is an issue with LochDNS or MyDNS, but DNS Report complains that this server does not respond on TCP, only UDP. How do I correct this?
Reply With Quote
  #23  
Old 14th April 2007, 14:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by SyberWizard
My final question, and I do not know if this is an issue with LochDNS or MyDNS, but DNS Report complains that this server does not respond on TCP, only UDP. How do I correct this?
Open /etc/mydns.conf and set
Code:
allow-tcp = yes
Then restart MyDNS.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #24  
Old 16th April 2007, 19:21
michaelkjohnson michaelkjohnson is offline
Junior Member
 
Join Date: May 2006
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
Arrow

Quote:
Originally Posted by SyberWizard
Thanks, that did it. It appears that port 80 does not work at all until after completing the rAA setup. It never occurred to me to go back and check it after setup!
I've never seen it not work at install time, but I do tend to use the virtual images rather than the anaconda image for testing point updates, and it's quite possible that I've just not noticed. I wonder if this had to do with the firewall, though?

Quote:
Originally Posted by SyberWizard
So, from the observations of a novice. There should be some guidance that:

need to turn off the firewall, as there is no selection for allowing DNS communications, OR add DNS ports to the firewall (better solution).

need to install the Everything selection in order to get MyDNS loaded. Can Everything be set as the default selection?

It would be great if that last screen mentioned that, in order to access the rAA setup, one must use port 8003/8004, and after completing setup, go back to the standard port 80.
I can tweak the firewall configuration for future releases.

I should simply disable the package selection screen so that all necessary software is always installed.

rAA should be modified to link to the MyDNSConfig console. You shouldn't need to go to rAA first; the landing page should be accessible as soon as you install, and it should point both to rAA and to MyDNSConfig.

Thanks for your detailed and useful response, and glad to hear that the system is working for you now (assuming falko's advice about allow-tcp = yes has resolved the other issue you encountered).
Reply With Quote
  #25  
Old 16th April 2007, 20:24
SyberWizard SyberWizard is offline
Junior Member
 
Join Date: Mar 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, it is now responding to TCP DNS requests, so that is working. Today I am working on the second DNS server, so I get to play with that functionality. I love it when progress is being made!
Reply With Quote
  #26  
Old 19th April 2007, 17:53
michaelkjohnson michaelkjohnson is offline
Junior Member
 
Join Date: May 2006
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
Arrow Update: Month of PHP bugs

Just a note for anyone worried about the security of their lochDNS systems due to security issues exposed during the "month of PHP bugs" -- as of last night, all updated lochDNS systems will include a new version of PHP that has been patched for the relevant security issues.
Reply With Quote
  #27  
Old 5th May 2007, 11:04
z00te z00te is offline
Junior Member
 
Join Date: May 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default dnscache

Hi,

i'm new to mydns, so looking the faq i found this answer to my problem:

http://mydns.bboy.net/faq/#9
-----
How do I use MyDNS but still allow external (recursive) lookups, like for "www.google.com"?
To do this you need to use a program that does recursive DNS lookups. I recommend dnscache.
----

the only solution is to install dnsccahe on the appliance?
other way to resolve non-local domain names?

tnx
z
Reply With Quote
  #28  
Old 5th May 2007, 13:04
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,769
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

The recommended way is to use a DNS cachcing program. e.g. dnsmasq as described in this howto:

http://www.howtoforge.com/mydns_mydn...on_ubuntu_edgy
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #29  
Old 6th May 2007, 20:18
z00te z00te is offline
Junior Member
 
Join Date: May 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Tnx for the link and the hint,

i have installed as the tutorial (well, adapting to rpath linux and using conary to install dnsmasq 2.38), and all seems to work from the virtual machine.
But from the others pc on the lan it seems that the caching function doesn't work; using dig to test the query time it seem too high.
No problem at all with the forward. Any idea on why the cache only works from the localhost... i've tried lot of config but no luck...

tnx
.z
Reply With Quote
  #30  
Old 7th May 2007, 17:19
michaelkjohnson michaelkjohnson is offline
Junior Member
 
Join Date: May 2006
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
 
Default finding and configuring dnsmasq

Quote:
Originally Posted by z00te
(well, adapting to rpath linux and using conary to install dnsmasq 2.38)
I want to be clear for other readers of this thread that dnsmasq is available for installation in lochDNS by running the command "conary update dnsmasq".

Quote:
But from the others pc on the lan it seems that the caching function doesn't work; using dig to test the query time it seem too high.
No problem at all with the forward. Any idea on why the cache only works from the localhost...
dnsmasq has a lot of configuration options, as you've discovered. I assume that you have tried increasing the cache size. The dnsmasq that I assume you have installed (from contrib.rpath.org@rpl:1) is set up primarily to integrate with dhcpcd as a local redirecting cache for laptop systems that are booted in different contexts at different times, and might have some subdomains that should be sought sometimes via ethernet and sometimes via VPN. In particular, the /etc/dnsmasq.conf file it includes contains the line "resolv-file=/etc/resolv.conf.static" which you probably want to comment out if you haven't already.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MyDNS and ISPConfig CoDonCo General 3 27th July 2006 08:25
MyDNS rude awaking kaptk2 HOWTO-Related Questions 16 19th May 2006 21:29
MyDNS CentOS start on Reboot kaptk2 HOWTO-Related Questions 8 3rd April 2006 04:54
making software changes to Suse 10 GermanyMontrealExpat Installation/Configuration 3 7th February 2006 11:53
MyDNSConfig 1.0.0 released falko General 8 25th January 2006 10:57


All times are GMT +2. The time now is 13:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.