#1  
Old 17th May 2006, 16:40
sfrank sfrank is offline
Junior Member
 
Join Date: May 2006
Posts: 22
Thanks: 0
Thanked 4 Times in 1 Post
Default adding new site

guys,

i'm not sure if it's a bug or feature so please advise. i've been using ISPConfig for 2 days so i'm not one of the founding members so to speak. :-)

well the first weird issue i encountered is that if i create a new site with 'Create DNS' option checked, it creates a 'www.domain.tld' and 'domain.tld' entry in the postfix local-host-names file, as well as a co-domain without the www (hostname) part, which is the normal behavior. that's fine.

however even if the 'Create DNS-MX' option is off it creates a "false" MX record for the www.domain.tld in the zone file. i say false, because the user does not want message to be addressed to his/her @www.domain.tld address, but the the @domain.tld only. by default at this point there is no MX record for the domain.tld, only for www.domain.tld - which actually was not requested.

secondly if i go to edit my co-domain domain.tld and check on the 'Create DNS MX' option it puts an MX entry in the same zone file in which MX record for www.domain.tld is declared in an order in which it cannot be resolved.

if MX records are in the following order in my zone file (the way ISPConfig puts them):

www MX 10 admin.domain.tld
MX 10 admin.domain.tld

here is what i get:

hathor:/# host -t mx site12.hu localhost
site12.hu has no MX record at localhost (Authoritative answer)
hathor:/# host -t mx www.site12.hu localhost
www.site12.hu MX 10 admin.domain.tld


if i change the order of these two entries, everything is fine. isn't that weird? does it work fine for other people?
Reply With Quote
Sponsored Links
  #2  
Old 17th May 2006, 16:43
sfrank sfrank is offline
Junior Member
 
Join Date: May 2006
Posts: 22
Thanks: 0
Thanked 4 Times in 1 Post
Default

furthermore if i add a site leaving the 'Hostname' field empty everything seems to be fine except one thing.

- DNS zone file is ok
- Apache vhost looks alright (both www.domain.tld and domain.tld is there)

however Postfix local-host-names does not contain domain.tld but www.domain.tld only. why? when i created a site without specifying a www hostname?

thanks for any hints and ideas.

frank
Reply With Quote
  #3  
Old 17th May 2006, 21:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

You must go to the DNS-Manager and remove unwanted DNS records there.
If you had checked the Default DNS and Default MX checkboxes and then unchecked them later on, this will not remove the DNS records, and it's intended that way because otherwise this might have some unwanted impacts. Only the admin and resellers should be allowed to change the DNS records in the DNS Manager.

Quote:
however Postfix local-host-names does not contain domain.tld but www.domain.tld only. why? when i created a site without specifying a www hostname?
Did you select "External Mailserver" for domain.tld?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 17th May 2006, 23:16
sfrank sfrank is offline
Junior Member
 
Join Date: May 2006
Posts: 22
Thanks: 0
Thanked 4 Times in 1 Post
Default

Quote:
Originally Posted by falko
You must go to the DNS-Manager and remove unwanted DNS records there.
If you had checked the Default DNS and Default MX checkboxes and then unchecked them later on, this will not remove the DNS records, and it's intended that way because otherwise this might have some unwanted impacts. Only the admin and resellers should be allowed to change the DNS records in the DNS Manager.
I can understand why a 'normal' user (not reseller, nor admin) cannot delete an already added MX record. That would make just confusions you're right. But my original question was that why domain.tld is not added to a domain as the default MX record instead of www.domain.tld even if the hostname www is defined on the site creation page? I don't think anyone would like to have a @www.domain.tld email address.

Quote:
Originally Posted by falko
Did you select "External Mailserver" for domain.tld?
I'm 99.95% sure that I did not. "Local Mailserver" is the default option though and I did not change it. I can double-check tomorrow, when I'm back to work.

Could you plz check if you add a site with no hostname specified what do you have in local-host-names concerning that particular domain (2.2.2)?

Thanks in advance.
Frank
Reply With Quote
  #5  
Old 18th May 2006, 08:34
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,561
Thanks: 791
Thanked 4,978 Times in 3,899 Posts
Default

Quote:
Originally Posted by sfrank
I don't think anyone would like to have a @www.domain.tld email address.
Maybe not www, but i know some companies that have email addresses with a country inside. e.g. @de.yourdomain.com. Thats why we add MX records with hostanme and without hostname.

Quote:
I'm 99.95% sure that I did not. "Local Mailserver" is the default option though and I did not change it. I can double-check tomorrow, when I'm back to work.

Could you plz check if you add a site with no hostname specified what do you have in local-host-names concerning that particular domain (2.2.2)?
ISPConfig creates a co-domain with empty host automatically. I just checked it again on ISPConfig 2.2.2
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 18th May 2006, 10:25
sfrank sfrank is offline
Junior Member
 
Join Date: May 2006
Posts: 22
Thanks: 0
Thanked 4 Times in 1 Post
Default

Quote:
Originally Posted by till
Maybe not www, but i know some companies that have email addresses with a country inside. e.g. @de.yourdomain.com. Thats why we add MX records with hostanme and without hostname.
OK, good call. But what I don't understand is, when you create a new site with www.domain.tld a co-domain gets created whose MX record cannot be resolved thru the nameserver, because the order of the MX records in the zone file is wrong. So on my system without further tweaking there's no way to receive email to @domain.tld addresses, because the sender does not know who is the authorized mailserver of domain.tld. Is it working fine for you?

If you create a new site let's say www.testsite.com, can you tell me what host -t mx testsite.com localhost shows you please?

Frank
Reply With Quote
  #7  
Old 18th May 2006, 19:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by sfrank
Is it working fine for you?
It's working fine for me, and I'm using ISPConfig to manage the DNS records of all my customers' domains.

Does
Code:
dig @localhost mx example.com
show the correct result?
The order of the records in the zone files doesn't matter.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 19th May 2006, 00:30
sfrank sfrank is offline
Junior Member
 
Join Date: May 2006
Posts: 22
Thanks: 0
Thanked 4 Times in 1 Post
 
Default

Quote:
Does
Code:
dig @localhost mx example.com
show the correct result?
The order of the records in the zone files doesn't matter.
That is insane. It's working fine with dig. I'll keep looking what might cause this anomaly. Anyways, sorry for the false alarm guys. :-\
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Site Skeletons rbartz Feature Requests 11 29th November 2008 16:07
After adding "Include vhosts/Vhosts_ispconfig.conf" httpd won;t startup mebusybody Installation/Configuration 14 2nd July 2008 17:30
Shared IP error when adding new site amoswright Installation/Configuration 15 15th June 2006 15:04
Removed site, but it is still there mromer General 2 21st December 2005 17:46
can't delete a site KenMcGinnis Installation/Configuration 2 14th August 2005 15:02


All times are GMT +2. The time now is 09:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.