Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > MyDNSConfig > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th March 2010, 10:38
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default does not answer

Hi,
I have done installation om debian Lenny, and all works fine, and use another server to resolv.

A have a test domain.com and i have point the domain to my servers IP address, and configure mydnsconfig to act as a master DNS for my domain.com i have put up a web server and mail server om another IP.

If i try dig and nslookup i got no response from the server, im sure my router i configure correctly.

i have no ide whats wrong and cant fint any error messages i the log files.
Reply With Quote
Sponsored Links
  #2  
Old 17th March 2010, 10:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Please post a screenshot of the domain settings in mydnsconfig for this test domain (the first tab and the records tab).
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th March 2010, 10:51
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default file

as requested

This DNS server has IP .60 at the end.
Attached Images
 

Last edited by trexen; 17th March 2010 at 10:56.
Reply With Quote
  #4  
Old 17th March 2010, 10:55
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default file2

as requested2
Attached Images
 
Reply With Quote
  #5  
Old 17th March 2010, 10:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

The zone tab is ok.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 17th March 2010, 11:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

You missed to add a dot at the end of the fully qualified domains names. In mydns and BIND, records that contain a fully qualified domain have to end with a dot.

The zone tab is ok.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 17th March 2010, 11:17
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default file3

it this the correct settings?
Attached Images
 
Reply With Quote
  #8  
Old 17th March 2010, 11:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

No. You missed to add the dots in the fqdn's in the data field. Something like ns1.domain.com is a fqdn (fully qualified domain name) and a fqdn has to end with a dot. So it must be ns1.domain.com. and mail.domain.com.

If you have relative records like "www", there is no dot at the end.

For example, your current MX record mail.domain.com. points to mail.domain.com.domain.com as it is currently a relative record and not a absolute.

I guess what you want is that emails for ...@domain.com gets delivered to the server mail.domain.com, the record for that will be:

name: domain.com.
data: mail.domain.com.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 17th March 2010, 11:34
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default file4

yes you right, i hope i correctmy mistakes
Attached Images
 
Reply With Quote
  #10  
Old 17th March 2010, 11:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
 
Default

Better but not fully correct. Please see what I posted above for the mx record. Data must be domain.com. and not mail. Otherwise you would be able to get only emails for ...@mail.domain.com but I guess you want to get emails for ...@domain.com

The ns record is fine.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
email / out of office / auto answer captnnuss Installation/Configuration 5 11th March 2010 09:29
Install Choice and Why..Sorry for the length! happz Installation/Configuration 19 26th October 2008 04:03
How used differently my file php.ini misterm Installation/Configuration 7 9th June 2008 19:44
How to harden a ldirector? P Lao Server Operation 4 2nd July 2006 06:00
Fedora 4 TPS mail.domain.com does not answer anymore Hagforce HOWTO-Related Questions 3 24th February 2006 12:10


All times are GMT +2. The time now is 12:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.