Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th February 2010, 23:46
bernholdt bernholdt is offline
Senior Member
 
Join Date: Jun 2007
Posts: 154
Thanks: 45
Thanked 13 Times in 11 Posts
Default Modsecurity2 on lenny dependecies problems?

Hi
i am trying to install modsecurity2 on my lenny box but i cant get it to work
I get this error when following this guide: http://howtoforge.org/apache2_mod_security_debian_etch
Quote:
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
apache2-prefork-dev: Conflicts: apache2-threaded-dev but 2.2.9-10+lenny6 is to be installed
apache2-threaded-dev: Conflicts: apache2-prefork-dev but 2.2.9-10+lenny6 is to be installed
mod-security2-common: Depends: libapache-mod-security2 (>= 2.5.5-1~etch1) but it is not installable or
libapache2-mod-security2 (>= 2.5.5-1~etch1)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
__________________
www.gamebook.me
Reply With Quote
Sponsored Links
  #2  
Old 21st February 2010, 12:33
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Default

Dis you try aptitude safe-upgrade instead already?
__________________
Hans

MrHostman | Master in managed hosting
Reply With Quote
  #3  
Old 21st February 2010, 15:53
bernholdt bernholdt is offline
Senior Member
 
Join Date: Jun 2007
Posts: 154
Thanks: 45
Thanked 13 Times in 11 Posts
 
Default

I solved it by 'apt-get -f install' as apt suggested
__________________
www.gamebook.me
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Lenny Xen Network Bridge Problems wmrwl HOWTO-Related Questions 4 30th September 2009 00:52
Problems following - Perfect Setup Debian Lenny ISPConfig3 GergOGerdy HOWTO-Related Questions 4 6th July 2009 12:11
Problems on creating Debian (Lenny) mirror tritsako HOWTO-Related Questions 3 24th June 2009 06:12
The Perfect Server - Debian Lenny ISPConfig 3 - but some deb install problems tom HOWTO-Related Questions 1 19th June 2009 15:55
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11


All times are GMT +2. The time now is 22:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.