Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th May 2006, 10:58
Mickey Loh Mickey Loh is offline
Junior Member
 
Join Date: May 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Wink User changing his or her own password

Hi all gurus,

Firstly, I am very very new to ISP Config. I finally manage to install ISP Config on a test server and allowing few users to test the functionality and features.

Ofcause they love it very much as it has the SPAM and AV feature that is included. We have not finalized the anything but I have two question already.

1. According to the user manual manual_kunde_en.pdf section 2.2.6 if Mailuser Login is activated for a site (tab "Basis"), a user can make changes himself to his email settings (password, spamfilter and antivirus settings) by logging in under https://www.domain.tld:81/mailuser or. http://www.domain.tld:81/mailuser:

I tried enabling the feature but I can't access either https://www.domain.tld:81/mailuser or. http://www.domain.tld:81/mailuser. What else should I configure any more?

2. Everytime I restart the server, when come loading ispconfig, I am require enter the certificate pass phrase else it will not continue. Is there a way to load the certificate at the same time no need to enter the pass phrase?
Reply With Quote
Sponsored Links
  #2  
Old 17th May 2006, 11:12
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Default question2

during install you should choose no for question 7 and 8
(as far as I remember)
otherwise he will always ask you question during reboot..
Reply With Quote
  #3  
Old 17th May 2006, 15:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by Mickey Loh
nual manual_kunde_en.pdf section 2.2.6 if Mailuser Login is activated for a site (tab "Basis"), a user can make changes himself to his email settings (password, spamfilter and antivirus settings) by logging in under https://www.domain.tld:81/mailuser or. http://www.domain.tld:81/mailuser:

I tried enabling the feature but I can't access either https://www.domain.tld:81/mailuser or. http://www.domain.tld:81/mailuser. What else should I configure any more?
You might have to append a slash to the URL (-> https://www.domain.tld:81/mailuser/ instead of https://www.domain.tld:81/mailuser ) if www.domain.tld differs from the ServerName in /root/ispconfig/httpd/conf/httpd.conf.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 3rd November 2006, 22:29
SoMBS SoMBS is offline
Junior Member
 
Join Date: Oct 2006
Location: New York
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Default Having this problem as well...

Quote:
Originally Posted by falko
You might have to append a slash to the URL (-> https://www.domain.tld:81/mailuser/ instead of https://www.domain.tld:81/mailuser ) if www.domain.tld differs from the ServerName in /root/ispconfig/httpd/conf/httpd.conf.
I tried this but did not work for me. I have searched quite a bit for a fix to this same problem. Going to either https://www.domain.tld:81/mailuser or https://www.domain.tld:81/mailuser does not allow me to access email user privileges. I do have Maildir checked in ISPConfig. I have sent and received email to and from this account so the mailboxes are working ok. I noticed the ServerName in /root/ispconfig/httpd/conf/httpd.conf was commented out so I uncommented and tried again with no luck. I went back and commented it back out because that's how it was after server install and ISPConfig set up. Not sure why it's commented out. I have read other posts regarding and haven't found a solution.

Any comments are appreciated.
Reply With Quote
  #5  
Old 4th November 2006, 18:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Do you use https or http for ISPConfig? If you use http, you must use http://www.domain.tld:81/mailuser/ .
If the trailing slash doesn't work, please try to use your IP address instead of www.domain.tld.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 4th November 2006, 20:42
SoMBS SoMBS is offline
Junior Member
 
Join Date: Oct 2006
Location: New York
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Do you use https or http for ISPConfig? If you use http, you must use http://www.domain.tld:81/mailuser/ .
If the trailing slash doesn't work, please try to use your IP address instead of www.domain.tld.
I use HTTPS. I tried it using the IP address of my server with and without the trailing slash. I get a web page that loads saying "Not Found
The requested URL /web1_user was not found on this server". I have no problem getting to the ISPConfig login so port 81 is forwarding through my router fine. I have verified Maildir is checked once again. I also unchecked it -> saved. Then went back and checked it again and saved it just to see if that would reset it. Worth a try...but still doesn't work. Possibly something in one of my config files?

I appreciate your time in helping me with this.
Reply With Quote
  #7  
Old 5th November 2006, 13:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,788
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

The error is correct, there is no such directory /web1_user on the server. Do not replace mailuser with the username in the URL!
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 5th November 2006, 16:45
SoMBS SoMBS is offline
Junior Member
 
Join Date: Oct 2006
Location: New York
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Til, that did the trick. Strange thing is that I tried using https://www.domain.tld:81/mailuser a number of times. That was before I disabled and then re enabled Maildir for the site. I did not try it again after I re enabled and was only trying with an actual username.

Once I was finally able to get the login screen I had trouble logging in. I tried several variations. username@domain.tld, web1_username, username, and none of these worked. So I checked my directories and the users were indeed there. I came back a short time later and tried again with web1_username and then it worked! I made no changes so I don't understand why it it didn't work the first time around. A script or function that runs at first login that causes a slight delay?

Just so that I understand. When we go to https://www.domain.tld:81/mailuser a function is run that states look at some location or file for list of usernames and what the actions their allowed to use? For instance when I go to /home/admispconfig/ispconfig/web/mailuser I can see the web pages that load for login, also the index page for mailuser page. But what I don't know is how or where it finds the users and what file it uses to authenticate the users password. Can you write a brief statement regarding or if it has been discussed in detail elsewhere point me to that forum discussion?

Thanks.
Reply With Quote
  #9  
Old 6th November 2006, 15:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

The users are stored in the ISPConfig database, and the code for the authentication is in /home/admispconfig/ispconfig/web/mailuser/login/.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 6th November 2006, 17:24
SoMBS SoMBS is offline
Junior Member
 
Join Date: Oct 2006
Location: New York
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Very good. My issue has been resolved. Thanks for the support.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40
Changing mysql password gfts Installation/Configuration 1 16th March 2006 18:39
what is the user name and password of the default ISPCongif page? nasir Installation/Configuration 1 13th March 2006 17:28
ISPConfig User and Password professordred Installation/Configuration 4 20th September 2005 22:48


All times are GMT +2. The time now is 23:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.