Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th February 2010, 12:39
kopite kopite is offline
Junior Member
 
Join Date: Feb 2010
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default Password protected folder help

Hey everyone.

I have been trying to password protect a folder using .htaccess and .htpasswd file

.htaccess file as follows.

Code:
uthName .Admin Area.
AuthType Basic
AuthUserFile /var/www/###.co.uk/.htpasswd
require valid-user
php_flag register_globals 1

Everytime I try and access the folder however i get an error 500. I have edited the vhost file for the domain and set AllowOverride All. But this still happens.

Any idea?
Reply With Quote
Sponsored Links
  #2  
Old 17th February 2010, 12:55
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,801
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

If you get an error in the browser, take a look in the error log of the website to find the reason for it.

In the first line of your .htaccess file is a typo, it must be:

AuthName "Admin Area"

and do not edit the vhost file manually as all manual edits will get removed automatically.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th February 2010, 13:01
kopite kopite is offline
Junior Member
 
Join Date: Feb 2010
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default

Spelling mistake isnt in the proper .htaccess file and was due to bad copypasta

The rror logs show:

[Wed Feb 17 11:36:07 2010] [alert] [client 212.23.9.240] /var/www/####.co.uk/web/test/.htaccess: AuthName takes one argument, The authentication realm (e.g. "Members Only")
Reply With Quote
  #4  
Old 17th February 2010, 13:13
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,801
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

Ok, then the error was what I posted above. Please change the line as I told you incl. the correct quotes.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th February 2010, 13:29
kopite kopite is offline
Junior Member
 
Join Date: Feb 2010
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

Doh I hadnt twigged on that the " had been changed to .

Feel like a complete idiot now

Thanks for the help till
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 11:49
Images not served by apache over a symbolic link folder hhhhhh Server Operation 0 27th January 2009 05:01
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40
Password Protected Directories Problem Median General 7 4th February 2006 18:15
Secure Page & Password Protected mphayesuk General 7 26th January 2006 18:30


All times are GMT +2. The time now is 16:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.