Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th January 2010, 11:59
pcxtra pcxtra is offline
Junior Member
 
Join Date: Nov 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default No Administrator checkbox visible

Since my upgrade to ISPconfig 2.2.35 I don't have a ' Administor' checkbox within the user e-mail form.

When I go to a site, and list the e-mail/users then I do see the admin column. However when I open a user then the checkbox 'Administrator' is gone and I cannot set / unset the site FTP administrator. I checked the form editor and it is nicely set to visible.

It dissapeared after I've upgraded to 2.2.35 about one week ago.
Reply With Quote
Sponsored Links
  #2  
Old 6th January 2010, 11:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,478
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

I will check this.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 6th January 2010, 12:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,478
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

There must be a problem with the update on your server. It seems to be that the doctype table has not been filled with the updated doctypes or that you installed a database of a prior ispconfig version.

Please download ISPConfig 2.2.35 again and run the setup script to do the update again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 12th February 2010, 23:21
pcxtra pcxtra is offline
Junior Member
 
Join Date: Nov 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks for your response however re-upgraded was not an option for me.

I had too much trouble already with the upgrade. Besides that I've modified some files. E.g. isp_username.plugin.php as I don't use the web prefix, but use the domainname.com_admin structure and isp_username.plugin.php to disallow to edit the e-mail. This allows users to login with their normal e-mail account (abc@domain.com). For dovecot I've added auth_username_format = "%Ld_%Ln" to allow also normal e-mail login. I've increased the user_username column of isp_isp_user to 50 and my linux fedora 12 allows the large user names (length of 38is my largest one).

Anyway, I manager to fix the loss of the Administrator checkbox. I first made a backup of the database. Used the form editor to changed the isp ISP user form and editted the current user_admin and renamed to user_admin2. Then I made a new user_admin checkbox with a name and defaults. Then I run an sql update:
update isp_isp_user set user_admin = user_admin2
this will restore the admin flags.

Now I'm able to see the administrator checkbox when I'm editing the e-mail details for a customer. So far it's working properly now!

So thanks to your direction I was managing to fix it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
create website again, but dns is not visible aurelius Installation/Configuration 1 9th October 2008 14:26
MailSpace MB is not visible Sarpenter Installation/Configuration 2 5th May 2008 09:16
MailSpace MB is not visible Sarpenter Installation/Configuration 1 5th May 2008 00:37
How to make visible folder on the web? lano Server Operation 2 7th October 2007 19:52
information_schema DB visible to all lex0429 Installation/Configuration 1 2nd June 2007 14:25


All times are GMT +2. The time now is 03:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.