#1  
Old 8th February 2010, 03:31
jeeva jeeva is offline
Junior Member
 
Join Date: Sep 2009
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Fixing my MySQL/PhpMyadmin

Hi

Currently running Fedora 11. Initially I used my dedicated server only for a SeedBox (with MySQL, Lighttpd:81, Torrentflux, php, etc, PsyBNC, Eggdrop) but recently I installed ISPconfig 3 (from the HowToForge guide Fedora + ISPConfig 3.0.1.6) above all of these.

The control panel etc is working, http://domain.com:8080/ (everything default settings), but when I create a database and try to access it via the webgui shortcut link from ISPConfig > Sites > Database:

http://domain.com/sites/database_phpmyadmin.php?id=3

it forwards to http://domain.com/phpmyadmin

Code:
Forbidden

You don't have permission to access /phpmyadmin on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.13 (Fedora) Server at
When I manual type a different database number [where 3 was, now 1] (which doesn't exist)
http://domain.com/sites/database_phpmyadmin.php?id=1

Code:
No DB-Server found!
if that is any clue.

I'm unable to login into my torrentflux control panel, so from what I gather my SQL settings changed somewhere if someone can please help me out and trying to get to fix it without having to reinstall my box.
Reply With Quote
Sponsored Links
  #2  
Old 8th February 2010, 11:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Please post the exact error message from the apache error log.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th February 2010, 13:54
jeeva jeeva is offline
Junior Member
 
Join Date: Sep 2009
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

/var/log/httpd/error-log

Code:
[Sun Feb 07 03:30:16 2010] [notice] Digest: generating secret for digest authentication ...
[Sun Feb 07 03:30:16 2010] [notice] Digest: done
[Sun Feb 07 03:30:17 2010] [notice] Apache/2.2.13 (Unix) DAV/2 PHP/5.2.12 mod_scgi/1.13 configured -- resuming normal operations
[Sun Feb 07 15:14:54 2010] [error] [client 222.186.25.125] File does not exist: /usr/local/ispconfig/interface/web/R.asp
[Sun Feb 07 15:18:16 2010] [error] [client 222.186.25.125] File does not exist: /usr/local/ispconfig/interface/web/R.asp
[Mon Feb 08 02:06:02 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:06:26 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:06:43 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:06:48 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:06:51 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:07:05 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:07:08 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:07:11 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:07:13 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:07:15 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:07:25 2010] [error] [client 196.209.195.87] PHP Notice:  Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc$
[Mon Feb 08 02:08:18 2010] [error] [client 196.209.195.87] client denied by server configuration: /usr/share/phpMyAdmin
[Mon Feb 08 02:08:19 2010] [error] [client 196.209.195.87] File does not exist: /usr/local/ispconfig/interface/web/favicon.ico
[Mon Feb 08 02:08:19 2010] [error] [client 196.209.195.87] File does not exist: /usr/local/ispconfig/interface/web/favicon.ico
[Mon Feb 08 02:08:22 2010] [error] [client 196.209.195.87] File does not exist: /usr/local/ispconfig/interface/web/favicon.ico
[Mon Feb 08 02:16:38 2010] [notice] caught SIGTERM, shutting down
[Mon Feb 08 02:16:42 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Feb 08 02:16:42 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Feb 08 02:16:42 2010] [notice] Digest: done
[Mon Feb 08 02:16:42 2010] [notice] Apache/2.2.13 (Unix) DAV/2 PHP/5.2.12 mod_scgi/1.13 configured -- resuming normal operations
[Mon Feb 08 02:17:33 2010] [error] [client 196.209.195.87] client denied by server configuration: /usr/share/phpMyAdmin
[Mon Feb 08 02:19:06 2010] [notice] caught SIGTERM, shutting down
[Mon Feb 08 02:19:07 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Feb 08 02:19:07 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Feb 08 02:19:07 2010] [notice] Digest: done
[Mon Feb 08 02:19:07 2010] [notice] Apache/2.2.13 (Unix) DAV/2 PHP/5.2.12 mod_scgi/1.13 configured -- resuming normal operations
Reply With Quote
  #4  
Old 8th February 2010, 14:22
digital-cipher digital-cipher is offline
Junior Member
 
Join Date: Feb 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem, if i type in the http://[hostname]:8080/phpmyadmin
its resolves fine tho.
Reply With Quote
  #5  
Old 8th February 2010, 14:23
jeeva jeeva is offline
Junior Member
 
Join Date: Sep 2009
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

http://domain:8080/phpmyadmin

Code:
Forbidden

You don't have permission to access /phpmyadmin on this server.
Reply With Quote
  #6  
Old 9th February 2010, 10:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Add the lines:

<Directory /usr/share/phpMyAdmin>
Order allow,deny
Allow from all
</Directory>

at the end of the file 000-ispconfig.conf file in the sites-anabled folder of your apache configuration and then restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
linus (20th March 2010)
  #7  
Old 9th February 2010, 14:55
jeeva jeeva is offline
Junior Member
 
Join Date: Sep 2009
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks for the help, last part worked. Forgot about the case sensitivity.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig With Mailman Guide calivent Developers' Forum 40 24th June 2010 17:37
Fixing open_basedir restriction runbuck General 2 28th December 2009 21:57
Thanks for fixing the remoting framework & other issues khayjake General 0 17th June 2009 12:22
need help fixing vsftpd auth fireba11 Installation/Configuration 1 6th January 2008 17:37
Fixing /var/log/httpd/error_log errors edge Server Operation 9 29th March 2006 10:36


All times are GMT +2. The time now is 06:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.