Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th February 2010, 04:14
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Exclamation HELP: Default Web location is /var and not /var/www

Ubuntu 8.04
Latest version of ispconfig

Why does ispconfig 3 think that /var is the main Document root.

With any new installs of ispconfig the default location is /var/www

Where or what file to I have to modifiy to allow ispconfig 3 to start creating sites under /var/www and not /var ?

I had moved the original client folder from /var to /var/www and re-created all the proper symlinks, which everything is working as far as browsing the sites go.

But any change from within the ispconfig 3 control panel, it created a whole new 'clients' folder in /var and doesn't modifiy the one that was moved. So any modifications through the CP only affect the Client sites under /var ant not the clients in /var/www.


So I just need to know 'what' is telling ispconfig that the default Web Root location is /var ?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 4th February 2010, 11:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Take a look in the ispconfig server settings and make sure that the correct path for symlinks and websites is set. It has to be:

website basedir: /var/www
website path: /var/www/clients/client[client_id]/web[website_id]
website symlinks: /var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 4th February 2010, 16:18
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
 
Thumbs up

OMG I was looking to deep into this. I was looking around for a specific config file that might contain that info and all this time it was in the CP...

Sorry for the stupid question man...

Ya, the website path was set to: /var/clients/client[client_id]/web[website_id]
Which I had modified.


Anyways I was able to migrate the existing 'client' folder from /var to /var/www and manually modified all symlinks and hardcoded paths in a few other files.

Ran into a couple issues but I was able to work them out and everything appears to be working as it should.

So I am now able to run suexec properly now too

Thanks again!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.