#1  
Old 1st February 2010, 23:32
modir modir is offline
Junior Member
 
Join Date: Dec 2009
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default Different directory for SSL

Within the user directory I would like to have two web directories. One for HTTP and one for HTTPS. Is it possible to do this with ISPconfig3? I would like to make the directories like this /web-http/ for HTTP and /web-https/ for HTTPS.
Reply With Quote
Sponsored Links
  #2  
Old 2nd February 2010, 11:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

You will have to change the code in the apache plugin to create the second directory and the path in the vhost template for the ssl vhost.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd February 2010, 12:24
modir modir is offline
Junior Member
 
Join Date: Dec 2009
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi Till,

Thank you for your information.

If I would extend the code in the way that it is selectable in the webinterface if it should be in the same or different directory, would you be interested in taking it into the main code? (If I get it right you are one of the main developers.)

Because then I would try to write more than a small hack.
Reply With Quote
  #4  
Old 2nd February 2010, 12:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
 
Default

Would be great if you like to make this feature available for all users, maybe add a checkbox on the ssl tab of the website to enable / disable it?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
directory structure, ssl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17


All times are GMT +2. The time now is 20:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.