Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Closed Thread
 
Thread Tools Display Modes
  #1  
Old 1st February 2010, 10:59
kipikipi kipikipi is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default PHP5 + Apache + mpm_worker fcgid problem

Hi there,
I've a problem using fcgid in apache for running php scripts (i'd like to run MediaWiki, i've no problem when i use mpm_prefork).
I saw many post about the subject but no one could resolve my problem.
here is my configuration :

--------------------------
/etc/apache2/mods-enabled/fcgid.conf :
<IfModule mod_fcgid.c>
Alias /wiki/ /srv/www/wiki/
MaxRequestsPerProcess 500
IPCConnectTimeout 60
<Location /wiki/>
AddHandler fcgid-script .php
Options +ExecCGI
FcgiWrapper /srv/php-wrapper .php
</Location>
</IfModule>

--------------------------
/etc/apache2/sites-enabled/default :
<VirtualHost *:80>
ErrorLog "/srv/log/default-error.log"
LogLevel debug
CustomLog "/srv/log/default-access.log"

DocumentRoot "/srv/www/"

<Directory /srv/www/wiki>
AllowOverride all
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

--------------------------
/srv/php-wrapper :
#!/bin/sh
PHP_FCGI_MAX_REQUESTS=10000
export PHP_FCGI_MAX_REQUESTS
exec /usr/bin/php5-cgi
--------------------------
With this config, i have in error log :
[debug] mod_cache.c(131): Adding CACHE_SAVE filter for /wiki
[debug] mod_cache.c(138): Adding CACHE_REMOVE_URL filter for /wiki
[debug] mod_deflate.c(615): [client 127.0.0.1] Zlib: Compressed 230 to 172 : URL /wiki
[debug] mod_cache.c(131): Adding CACHE_SAVE filter for /wiki/
[debug] mod_cache.c(138): Adding CACHE_REMOVE_URL filter for /wiki/
[warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[error] [client 127.0.0.1] Premature end of script headers: index.php
[debug] mod_deflate.c(615): [client 127.0.0.1] Zlib: Compressed 539 to 321 : URL /wiki/index.php


I've try to increase values of MaxRequestsPerProcess and IPCConnectTimeout, because I saw it solved the problem for some people.... But nothing for me !

Please, someone could help ?
Sponsored Links
  #2  
Old 2nd February 2010, 15:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #3  
Old 2nd February 2010, 15:16
kipikipi kipikipi is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I use debian Linux. But I found my error since yesterday ... sorry to not post it... My error was I had not gave the good rights to php-wrapper script (not executable and not accessible by www-data).
Thanks for reply ! You can mark thread as resolved ^^
Closed Thread

Bookmarks

Tags
apache, conf, fcgid, php, premature

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
Aptitude apache mdm-itk problem Lord_Garfield Installation/Configuration 0 24th November 2009 08:53
BIG Problem Postfix issue admins Installation/Configuration 11 13th November 2009 10:05
lighttpd vs apache problem marra87 Server Operation 0 28th January 2009 23:05
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 08:04


All times are GMT +2. The time now is 15:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.