Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st February 2010, 06:52
techman83 techman83 is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Gallery 2 on Debian Lenny/ISPConfig3 [SOLVED]

Hi All,

Got what will hopefully be a quick one. Just done a fresh install with Debian 5, Ispconfig3 with Falko's Perfect Setup guide. Which got me up and running nicely.

What I'm having a problem with is that unless I put my Galleries data directory under web/ (which isn't recommended) Gallery 2 comes up with an error:

Code:
Error: Some files and or directories in your storage directory are not writeable by the webserver user. 
Run chown -R webserverUser /var/www/gallery.techieman.net/web/g2data/ OR 
run chmod -R 777 /var/www/gallery.techieman.net/web/g2data/.
I've tried owning it with the right "web:client" and also the apach user "www-data" and even trying 777 (shouldn't be necessary). I don't think SElinux is enabled as running a "ls -Z" just lists question marks next to all the directories.

My only guess is that something in Apache is preventing Gallery from accessing any files outside of web/.

Any help/general prods in the right direction would be much appreciated.

Leon

Last edited by techman83; 1st February 2010 at 12:03. Reason: marking solved
Reply With Quote
Sponsored Links
  #2  
Old 1st February 2010, 08:39
damir damir is offline
Senior Member
 
Join Date: Jun 2006
Posts: 375
Thanks: 11
Thanked 51 Times in 42 Posts
Default

Do you have right paths in G2 config file?
Reply With Quote
  #3  
Old 1st February 2010, 08:44
techman83 techman83 is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yep, I can confirm that. When I moved it under web/ it worked fine. I even tried moving it to /g2data with correct perms, just to take all the complexity out, to no avail.

Thanks,

Leon

EDIT: To note, above error shows the working path, but I moved it back out after confirming I could get it to work somewhere. Re-tested with path outside web/, still got error

Last edited by techman83; 1st February 2010 at 08:47. Reason: extra info
Reply With Quote
  #4  
Old 1st February 2010, 09:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

The access for files outside of the website dir is forbidden for security reasons. If you want this, you will have to edit the php open_basedir path in the vhots template and the cgi and fcgi starter templates.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st February 2010, 09:17
techman83 techman83 is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's definitely it. I changed the vhost file under sites enabled and it worked. I'm assuming if I make any changes to the site from the panel, it will overwrite those changes, but it'll do for the time being until I have time to learn how to make a custom template and apply it to that site (if it's possible).
Reply With Quote
  #6  
Old 1st February 2010, 09:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

As I posted above, you should have changed the vhost template and not the vhost file as all changes that you did in the vhost file get removed automatically. The templates are in /usr/local/ispconfig/server/conf/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 1st February 2010, 09:28
techman83 techman83 is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks, Found and done!
Reply With Quote
Reply

Bookmarks

Tags
apache2, debian lenny, gallery2, ispconfig3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[debian 5 + ispconfig 3] Unable to send mail tanakskool HOWTO-Related Questions 6 4th November 2009 18:20
gallery on debian 40 with ispconfig hbellmer Installation/Configuration 7 3rd April 2008 02:55
Please help me whit bind9 astra2000 Server Operation 12 10th October 2007 02:43
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 04:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.