#1  
Old 15th May 2006, 10:32
cpcpy cpcpy is offline
Member
 
Join Date: Feb 2006
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix configuration - relay

i have followed the perfect setup for ispconfig (2.1.2) and FC4
and everything works fine...

i realised that recently another machine in the same subnet (belong to someone else) is using my server to relay spams...

i'd like to set in my main.cf such that
mynetworks_style = host (to send out mails from my machine only, not my network)

however, i notice that the output of postconf does not change when i set "mynetworks_style = host" in /etc/postfix/main.cf

===============================
# postconf -d | grep mynetworks

mynetworks = 127.0.0.0/8 203.81.39.0/24
mynetworks_style = subnet
===============================

i did not set "mynetworks", so it seems that postfix gets the value (203.81.39.0/24) somewhere else.

according to the man pages, if "mynetworks" is set, then "mynetworks_style" will be ignored.

am i missing anything?

how can i set "mynetworks_style = host" ?

thanks
Reply With Quote
Sponsored Links
  #2  
Old 15th May 2006, 15:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Just set
Code:
mynetworks = 127.0.0.0/8
and comment out mynetworks_style.
Then restart Postfix. This will allow sending only from localhost (without authentication).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th May 2006, 17:10
cpcpy cpcpy is offline
Member
 
Join Date: Feb 2006
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Just set
Code:
mynetworks = 127.0.0.0/8
and comment out mynetworks_style.
Then restart Postfix. This will allow sending only from localhost (without authentication).
my server is currently hosting a few domains and have a few IP addresses
would there be any problem by doing the above?
Reply With Quote
  #4  
Old 15th May 2006, 17:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,214 Times in 4,089 Posts
Default

No, there shall be no problems.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th May 2006, 08:30
cpcpy cpcpy is offline
Member
 
Join Date: Feb 2006
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko
Just set
Code:
mynetworks = 127.0.0.0/8
and comment out mynetworks_style.
Then restart Postfix. This will allow sending only from localhost (without authentication).
thanks - this works for me...

actually there was a problem with my earlier command...
should have omitted the -d and i think i'll be ok

===============================
# postconf -d | grep mynetworks

mynetworks = 127.0.0.0/8 203.81.39.0/24
mynetworks_style = subnet
===============================
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to enable SMTP Relay on POSTFIX slygeek Server Operation 3 4th May 2006 11:12
SMTP Relay on POSTFIX slygeek Installation/Configuration 1 3rd May 2006 14:45
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 19:29
Bug? (postfix refuses mail, relay access denied) st2xo General 2 31st January 2006 16:00
please help: postfix design and configuration jaguar Installation/Configuration 1 9th December 2005 11:46


All times are GMT +2. The time now is 22:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.