Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd September 2005, 05:47
ahuen ahuen is offline
Junior Member
 
Join Date: Sep 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default isp manager - can't create reseller, client, hosting plan etc

All,

I just got the ISPConfig 2.0.8 installed and when I tried to create a reseller, client, hosting plan, new site etc in the ISP manager section i get "The requested document type does not exist" I looked in the php file ispconfig\web\isp_kunde\new\kunde.php and it seems like it is refering doctype_id =1012 and i checked in my db the doc definition is there.

in kunde.php
header("Location: ../../multidoc/edit/edit.php?doctype_id=1012&s=$s");

pls help.

Thanks.
Al
Reply With Quote
Sponsored Links
  #2  
Old 2nd September 2005, 09:02
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

Quote:
Originally Posted by ahuen
All,

I just got the ISPConfig 2.0.8 installed and when I tried to create a reseller, client, hosting plan, new site etc in the ISP manager section i get "The requested document type does not exist" I looked in the php file ispconfig\web\isp_kunde\new\kunde.php and it seems like it is refering doctype_id =1012 and i checked in my db the doc definition is there.

in kunde.php
header("Location: ../../multidoc/edit/edit.php?doctype_id=1012&s=$s");

pls help.

Thanks.
Al

Have you disabled cookies in your browser?
Reply With Quote
  #3  
Old 2nd September 2005, 14:37
ahuen ahuen is offline
Junior Member
 
Join Date: Sep 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Have you disabled cookies in your browser?
Cookie is enabled. Still no go. pls help.

thx
Al
Reply With Quote
  #4  
Old 2nd September 2005, 14:54
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

Quote:
Originally Posted by ahuen
Cookie is enabled. Still no go. pls help.
Can you please try another browser (e.g. firefox) with default security settings.

the error "The requested document type does not exist" is shown when you call a non existant document type or when the doctype_id variable is empty.

Have you cnahnge settings in the php.ini of the controlpanel PHP?
Reply With Quote
  #5  
Old 2nd September 2005, 15:25
ahuen ahuen is offline
Junior Member
 
Join Date: Sep 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Till,

just tried in firefox. got the same error. i did not change the php.ini.
however when i did the install of ISPConfig it did not load the tables or data. I had to run the install_ispconfig/db_ispconfig.sql manually. It could be data related.

Can I get a db dump for a clean install, if you have one?

Thanks.
Al
Reply With Quote
  #6  
Old 2nd September 2005, 15:28
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

Quote:
Originally Posted by ahuen
Till,

just tried in firefox. got the same error. i did not change the php.ini.
however when i did the install of ISPConfig it did not load the tables or data. I had to run the install_ispconfig/db_ispconfig.sql manually. It could be data related.

Can I get a db dump for a clean install, if you have one?

Thanks.
Al
OK, that makes the situation clearer. No, you cant install ISPConfig by installing the sql-dump manually. Please uninstall ISPConfig by executing:

/root/ispconfig/uninstall

Then reinstall ispconfig. If you get any errors or problems, post them here we will help you to get around them.
Reply With Quote
  #7  
Old 2nd September 2005, 15:33
ahuen ahuen is offline
Junior Member
 
Join Date: Sep 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Till,

Thanks for the heads up but it there we no error messages for creating the db. I tried reinstalling many times and it behaves the same way. Please advice.

Ientered the following values and no errors.

Please enter your MySQL server: localhost
Please enter your MySQL user: root
Please enter your MySQL password: mypassword
Please enter a name for the ISPConfig database: ispconfig_db

thanks.
Al
Reply With Quote
  #8  
Old 2nd September 2005, 15:37
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

Quote:
Originally Posted by ahuen
Till,

Thanks for the heads up but it there we no error messages for creating the db. I tried reinstalling many times and it behaves the same way. Please advice.

Ientered the following values and no errors.

Please enter your MySQL server: localhost
Please enter your MySQL user: root
Please enter your MySQL password: mypassword
Please enter a name for the ISPConfig database: ispconfig_db

thanks.
Al
Do you have any exotic characters in your mySQL password? If so, please change it for the setup. You can change it later in the ISPConfig config file.

Have you disabled "skip-networking" in your mySQL configuration? I(SPConfig connects via TCP sockets on localhost.

Before you reinstall, delete ispconfig_db or use an other db name for the next install, dont know if this can cause trouble
Reply With Quote
  #9  
Old 2nd September 2005, 15:53
ahuen ahuen is offline
Junior Member
 
Join Date: Sep 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Till,

when i did the uninstall it says

No results found!

I am whacking the db, and reinstalling ispconfig.

Will let you know the results.

Thanks.
Al
Reply With Quote
  #10  
Old 2nd September 2005, 16:03
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
 
Default

Quote:
Originally Posted by ahuen
Till,

when i did the uninstall it says

No results found!

I am whacking the db, and reinstalling ispconfig.

Will let you know the results.

Thanks.
Al
If the uninstall script does not work correctly, delete the two directories

/root/ispconfig
/home/admispconfig

manually before you reinstall.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.