Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th May 2006, 07:11
kong121s kong121s is offline
Member
 
Join Date: Apr 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPconfig didn't start when reboot

before I have this problem , I have e-mail problem which I can't send or receive mail.
It sucessfully logs into my mailserver but whenever I try to send a message it says "Relay access denied."

so, I tried to config hostname and DNS.
But it doesn't work and make me this problem.
I tried to config default value but it still have this problem T_T
detail of my problem is :
I must login to my server by putty and run /etc/init.d/ispconfig_server start by myself after reboot server. and then run /etc/init.d/proftpd start , /etc/init.d/sendmail start .

Please help me. thank you

and please answer this knowless question:
How to see a boot time error log??

Last edited by kong121s; 15th May 2006 at 11:18.
Reply With Quote
Sponsored Links
  #2  
Old 15th May 2006, 09:28
kong121s kong121s is offline
Member
 
Join Date: Apr 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

oh! I found an error that may be cause of my problem.

I can't start postfix !!
Where I can see logs of postfix?
Reply With Quote
  #3  
Old 15th May 2006, 10:51
kong121s kong121s is offline
Member
 
Join Date: Apr 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

sorry. It's my misunderstand about postfix.
It can start but please look this

Code:
[root@www /]# /etc/init.d/postfix status
master is stopped
[root@www /]# /etc/init.d/postfix start
Starting postfix:                                          [FAILED]
[root@www /]# /etc/init.d/postfix restart
Shutting down postfix:                                     [FAILED]
Starting postfix:                                          [  OK  ]
[root@www /]# /etc/init.d/postfix status
master is stopped
[root@www /]#
!!!!

Last edited by kong121s; 15th May 2006 at 11:11.
Reply With Quote
  #4  
Old 15th May 2006, 15:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

What's in your mail log? The log is usually in /var/log.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th May 2006, 04:44
kong121s kong121s is offline
Member
 
Join Date: Apr 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is a log (/var/log/maillog) when I login to webmail and send from web1 to web2

Code:
May 16 09:30:57 www postfix/postfix-script: starting the Postfix mail system
May 16 09:30:57 www postfix/master[32482]: fatal: bind 0.0.0.0 port 25: Address already in use
May 16 09:31:49 www dovecot: pop3-login: Login: user=<web1_test>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
May 16 09:31:49 www dovecot: pop3(web1_test): Logout. top=0/0, retr=0/ del=0/0, size=0
May 16 09:32:09 www sendmail[32659]: k4G2W9cK032659: from=<test@test.com>, size=480, class=0, nrcpts=1, msgid=<200605160232.k4G2W9cK032659@www.centorythailand.com>, proto=SMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
May 16 09:32:09 www dovecot: pop3-login: Login: user=<web1_test>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
May 16 09:32:09 www dovecot: pop3(web1_test): Logout. top=0/0, retr=0/ del=0/0, size=0
May 16 09:32:09 www sendmail[32661]: k4G2W9cK032659: to=<webmaster@b4ninety.com>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=120480, relay=b4ninety.com. [###.##.##.##], dsn=4.0.0, stat=Deferred: Connection refused by b4ninety.com.
May 16 09:32:19 www dovecot: pop3-login: Login: user=<web2_test>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
May 16 09:32:19 www dovecot: pop3(web2_test): Logout. top=0/0, retr=0/ del=0/0, size=0
There is something that I just found.
It can't start postfix because sendmail is running. I must stop sendmail then I can start postfix as well.
so, I redo "Postfix With SMTP-AUTH And TLS" in Perfect setup for fedora core 5.
but It still not run ISPConfig after reboot.

and... still can't receive any email from anyone.
I can send mail from web2 to anywhere (except in my server).
but I can't send mail from web1 which I didn't register it on worldwide (web2 is registered)

Last edited by kong121s; 16th May 2006 at 11:52.
Reply With Quote
  #6  
Old 16th May 2006, 11:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,173 Times in 4,055 Posts
Default

With unregistered website you mean a fake domain like myserver.int ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 16th May 2006, 11:50
kong121s kong121s is offline
Member
 
Join Date: Apr 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry about my english. English language isn't my main language.

unregister is mean... I didn't register domain for that website.
(um.. hard to explain for me. please go to http://www.udomain.net/en/main/index.php <<< somewhere to register domain.
Hope you understand
)
Reply With Quote
  #8  
Old 16th May 2006, 16:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
 
Default

You must register the domain first before you can use it.

In order to make Postfix and ISPConfig start at boot time, run this:

Code:
chkconfig --levels 235 sendmail off
chkconfig --levels 235 postfix on
chkconfig --levels 235 ispconfig_server on
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HowTo start developing ISPConfig till Developers' Forum 18 25th April 2014 20:43
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16
MyDNS CentOS start on Reboot kaptk2 HOWTO-Related Questions 8 3rd April 2006 04:54
Warning on ispconfig start bin-online General 4 3rd March 2006 20:11
start again from scratch with ispconfig - how? Ovidiu General 1 19th September 2005 11:05


All times are GMT +2. The time now is 09:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.