Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th January 2010, 21:58
sadnem sadnem is offline
Junior Member
 
Join Date: Jan 2010
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Default Internal Server Error when executing .cgi files

Hello, Im trying to install Movable Type 5 on my server and Im getting an Internal Server Error, I have uploaded the files using ASCII modes, the owner of the folder is ispconfig user and not root, cgi is enabled on the domain, Ive tried to do all that i found searching on this forum but it didnt work, what should i do?

PS: I forgot to install squirremail before ispconfig, and now its not working mydomain.com/webmail gives me an 404 error is this reparable?
Reply With Quote
Sponsored Links
  #2  
Old 13th January 2010, 22:42
fawkes fawkes is offline
Junior Member
 
Join Date: Jan 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

404 must be a missing symlink...



try this:
Code:
ln -s /usr/share/squirrelmail/ /var/www/webmail
Reply With Quote
  #3  
Old 13th January 2010, 23:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

Quote:
Hello, Im trying to install Movable Type 5 on my server and Im getting an Internal Server Error, I have uploaded the files using ASCII modes, the owner of the folder is ispconfig user and not root, cgi is enabled on the domain, Ive tried to do all that i found searching on this forum but it didnt work, what should i do?
Take a look in the error log of the website and post the exact error message that is listed there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 14th January 2010, 04:09
sadnem sadnem is offline
Junior Member
 
Join Date: Jan 2010
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Which file should i post here?
Reply With Quote
  #5  
Old 14th January 2010, 12:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Apache's error log.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 14th January 2010, 21:34
sadnem sadnem is offline
Junior Member
 
Join Date: Jan 2010
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Default

This is the /var/www/clients/client1/web2/log/error.log content:
Code:
[Thu Jan 14 20:32:53 2010] [error] [client 89.141.98.120] suexec policy violation: see suexec log for more details
[Thu Jan 14 20:32:53 2010] [error] [client 89.141.98.120] Premature end of script headers: mt.cgi

Last edited by sadnem; 14th January 2010 at 21:50.
Reply With Quote
  #7  
Old 14th January 2010, 21:39
sadnem sadnem is offline
Junior Member
 
Join Date: Jan 2010
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Default

And im also having other problem, subdomain.domain.ltd/cgi-bin/ doesnt exist so i havent figured out how to execute cgis on subdomains via /cgi-bin/ and not .htaccess and so on. (but now even i execute them with an .htaccess i got an Internal Error because of the posted there)
Reply With Quote
  #8  
Old 15th January 2010, 14:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Do you have a suexec log somewhere on your system? E.g. in /var/log/ or /var/log/apache2/ or /var/log/httpd/? Are there any errors in it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 15th January 2010, 19:23
sadnem sadnem is offline
Junior Member
 
Join Date: Jan 2010
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Suexec log:
Code:
[2010-01-14 20:32:53]: uid: (5005/web2) gid: (5005/5005) cmd: mt.cgi
[2010-01-14 20:32:53]: target uid/gid (5005/5005) mismatch with directory (0/0) or program (0/0)
[2010-01-14 20:39:57]: uid: (5005/web2) gid: (5005/5005) cmd: mt.cgi
[2010-01-14 20:39:57]: target uid/gid (5005/5005) mismatch with directory (0/0) or program (0/0)
[2010-01-14 20:39:59]: uid: (5005/web2) gid: (5005/5005) cmd: mt.cgi
[2010-01-14 20:39:59]: target uid/gid (5005/5005) mismatch with directory (0/0) or program (0/0)
[2010-01-14 20:40:00]: uid: (5005/web2) gid: (5005/5005) cmd: mt.cgi
[2010-01-14 20:40:00]: target uid/gid (5005/5005) mismatch with directory (0/0) or program (0/0)
Reply With Quote
  #10  
Old 16th January 2010, 12:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
 
Default

The cgi file mt.cgi is owned by the wrong linux user. Please correct the owner of the file so that it is the same then the user and group of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
apache2 won't connect to localhost or 127.0.0.1 anw Server Operation 6 19th March 2009 19:51
cacti problem - graphs have huge gaps Chip Installation/Configuration 7 8th February 2008 00:24
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 17:11
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 16:44
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 01:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.